Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Mirc causes Disconnect


  • Please log in to reply

#1
Oblivionon360

Oblivionon360

    Member

  • Member
  • PipPipPip
  • 261 posts
When i Launch Mirc and tell it to connect, it does but then immediatly after my internet disconnects, which in turn causes Mirc to loose connection to the server. Im running on a D-link router using comcast cable internet, running through my computers built in wireless card. its just a vicious cycle i can't seem to figure out how to correct. ive tried looking up Port settings for Mirc to set my D-link to allow the listen port. But despite all attemps, all threads, forums, and guides all refer to an older version of Mirc. If anyone could help resolve this issue it would be great
  • 0

Advertisements


#2
PedroDaGR8

PedroDaGR8

    Member

  • Member
  • PipPipPip
  • 786 posts

When i Launch Mirc and tell it to connect, it does but then immediatly after my internet disconnects, which in turn causes Mirc to loose connection to the server. Im running on a D-link router using comcast cable internet, running through my computers built in wireless card. its just a vicious cycle i can't seem to figure out how to correct. ive tried looking up Port settings for Mirc to set my D-link to allow the listen port. But despite all attemps, all threads, forums, and guides all refer to an older version of Mirc. If anyone could help resolve this issue it would be great


Ok is there any way you can temporarily bypass the router i.e. hook your computer in via ethernet to the cable modem? This may or may not work due to the way cable providers assign IP addresses (usually they set the internet up on one computer or router and the MAC address of that device is what is given the IP). That being said, if you hardwire it and you can access the internet properly, then try mIRC. If it works properly we now know the problem is either your wireless card or the router (I would say router as wireless cards typically don't care WHAT is sent).

EDIT: Actually lets try this first. See if your router has a setting called DMZ aka Demilitarized Zone. It basically buts whatever device with the DMZ IP in FULL contact with the internet. Lets try this first before physical removal of the router. If it DOES have a DMZ option, set the DMZ IP to the one used by your computer. This then puts your computer in the DMZ. Now try mIRC. If it works, it is a router setting thing and we will get to the bottom of this, NEVER EVER EVER leave your computer in the DMZ though, it is like connecting it straight to the internet with no router in between.

Edited by PedroDaGR8, 10 January 2009 - 09:05 AM.

  • 0

#3
Oblivionon360

Oblivionon360

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 261 posts
Well DMZ got me just a tad further. Now it is telling me that software cause a connection failure. and agian everytime it connects it resets my wireless on the laptop and agian, vicious cycle

Edited by Oblivionon360, 10 January 2009 - 01:05 PM.

  • 0

#4
Oblivionon360

Oblivionon360

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 261 posts
So, ive still had no luck with Mirc and i've come to find out that it not only disconnects me from the internet but it also disconnects my xbox and any other computers that may be connected on my internet. Yes as I stated above i tried allowing DMZ. It did not help what so ever. It keeps telling me 10053 software caused connection failure. ive read a couple other sites that say to put in a diferent domain host or ip but im not sure what domain im supposed to use. Is there another IRC chat client that might provide better stability and actually allow me to connect for more than 2 seconds? i've had this post up for about 5 days and im beginning to wonder if im just out of luck.
  • 0

#5
PedroDaGR8

PedroDaGR8

    Member

  • Member
  • PipPipPip
  • 786 posts

i've come to find out that it not only disconnects me from the internet but it also disconnects my xbox and any other computers that may be connected on my internet.


Ok this is a key point here. This tells me it is something to do with your router, not the mIRC software. For some reason your router is seeing the IRC request and just freaking out and killing the connection. WHat model and model number of router is this?

Edited by PedroDaGR8, 12 January 2009 - 10:00 PM.

  • 0

#6
Oblivionon360

Oblivionon360

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 261 posts
My router is a D-Link Model# : DI-524. When i was looking around the settings for the router i noticed a section called zone alarm. It is using somthing called ZAP Alarm. Could this be the problem? It says further down on the same page that the exempt ips are from 123.456.0.0 to 123.456.0.0 So if i make my static ip for my laptop the only one exempt could this fix my problem?
  • 0

#7
PedroDaGR8

PedroDaGR8

    Member

  • Member
  • PipPipPip
  • 786 posts
Unfortunately, I don't think that will help. Try forwarding ports 1200-5400 to your computer. Though I couldn't find anything about IRC causing problems with your router.
  • 0

#8
Oblivionon360

Oblivionon360

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 261 posts
Ok, now do i open those ports in the virtual or the firewall? i know with my xbox i had to do both but the problem is with the virtual it only allows one port at a time where as the firewall allows a port 120 to port 1300
  • 0

#9
PedroDaGR8

PedroDaGR8

    Member

  • Member
  • PipPipPip
  • 786 posts
No I want you to enter 5200 of those manually. :) j/k

First try the firewall. If htat doesn't help I'll look for some more precise numbers for the virtual.
  • 0

#10
Oblivionon360

Oblivionon360

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 261 posts
also my firewall has a section asking what type of protocol I want UDP, TCP, ICMP. And any ideas where i might find those precise numbers?

Edited by Oblivionon360, 12 January 2009 - 10:46 PM.

  • 0

Advertisements


#11
PedroDaGR8

PedroDaGR8

    Member

  • Member
  • PipPipPip
  • 786 posts
Set it up as both TCP and UDP and actually extend it up to 7000 since you can do ranges.
  • 0

#12
PedroDaGR8

PedroDaGR8

    Member

  • Member
  • PipPipPip
  • 786 posts
Also on your virtual do ports 6665-6670 TCP and UDP. Once you have done this, see if you get the same problem.
  • 0

#13
Oblivionon360

Oblivionon360

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 261 posts
Nope, Nothing helped. It's still disconnecting everything all at once when mirc connects is there another IRC that will be better off to use?
  • 0

#14
PedroDaGR8

PedroDaGR8

    Member

  • Member
  • PipPipPip
  • 786 posts
http://www.valinor.s...ms-windows.html

is a list of windows IRC clients. That being said, I hope that a change works but I have a feeling this is a problem with your router.
  • 0

#15
sari

sari

    GeekU Admin

  • Administrator
  • 20,959 posts
  • MVP
Since this happened with both the Java applet and mIRC, I agree with Pedro - this is more an issue with something on your router than with the software itself.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP