Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Firefox 3 strange symbols in place fo text for some websites


  • Please log in to reply

#1
eist

eist

    New Member

  • Member
  • Pip
  • 4 posts
I just reinstalled Firefox 3 and am finding that on certain websites strange symbols are displaying in place of the intended text. I had this problem before (but with different kinds of symbols) and had to dump some fonts. The same problem is occurring with those websites in safari. I am a designer, so I have a ton of fonts. I just don't know which one to dump this time.

Below is a screen shot:

Posted Image

Thank you!!
Maria
  • 0

Advertisements


#2
Major Payne

Major Payne

    Retired Staff

  • Retired Staff
  • 5,307 posts
Go to the site again and then try changing your Character Encoding from the View menu. If none work, you may not have the font that will work with the character encoding to diplay the text that page requires. A link to the site would be helpful.

Edited by Major Payne, 17 January 2009 - 02:57 PM.

  • 0

#3
Battle Unit

Battle Unit

    Member

  • Member
  • PipPip
  • 40 posts
I think it's a problem with the websites, some kind of mess with character encoding of files
  • 0

#4
eist

eist

    New Member

  • Topic Starter
  • Member
  • Pip
  • 4 posts
I tried changing my Character Encoding from the View menu, but that didn't work. And I am pretty sure I have every font known to man on my computer. Also this happens on about 20% of the sites I have been to -- ones that have not been a problem in the past.

I know these sites are picking up a font they should not, i just need to find out which one....

Thanks.
  • 0

#5
Major Payne

Major Payne

    Retired Staff

  • Retired Staff
  • 5,307 posts
Would you give links to the sites? It has to be the right combination of character encoding set in your browser and the font family being used. Otherwise, you will get strange characters. Sometimes, just question marks or blank little squares.
  • 0

#6
eist

eist

    New Member

  • Topic Starter
  • Member
  • Pip
  • 4 posts
yes -- quite right. Here is an example:
http://www.gutenberg.../wiki/Main_Page

Thanks for any ideas...!
  • 0

#7
eist

eist

    New Member

  • Topic Starter
  • Member
  • Pip
  • 4 posts
And this is what it looks like on my computer:

Posted Image
  • 0

#8
Major Payne

Major Payne

    Retired Staff

  • Retired Staff
  • 5,307 posts
Definitely is a problem with your browser and not the site. Looks normal to me. My character encoding is set to Western (ISO-8859-1) and the font is using the font either from the site or my PC. Didn't look at their code to see what font family they called, but my browser's default font is Times New Roman.

I am using Firefox 2.0.0.20. Site displayed just fine in Opera, Maxthon and IE 7 for me.

Edited by Major Payne, 19 January 2009 - 05:36 PM.

  • 0

#9
yanksno1

yanksno1

    New Member

  • Member
  • Pip
  • 1 posts
I'm having a similar problem on my PC. It only happens in FF 3.0.5. It looks fine on IE, so I'm sure it's not the PC. Basically on certain fonts I can't read them. They're in scrambled characters, as shown in the image below. Any suggestions on how to fix this problem? :)

Posted Image
  • 0

#10
Major Payne

Major Payne

    Retired Staff

  • Retired Staff
  • 5,307 posts
@ yanksno1: Please do not hi-jack someone else's topic. The same advice given should fit your problem. Check your browser's Character Encoding and default font set. If you set your browser to override font settings for web sites because you like a certain font, then you may get a screwed up mess of characters.
  • 0

#11
Parey

Parey

    New Member

  • Member
  • Pip
  • 1 posts
One thing I have found that makes the 3 symbols go away - temporarily is to change the Firefox character encoding from Western(IS0-8859-1) to Unicode(UTF-8).
  • 0

#12
SlowMotionCommotion

SlowMotionCommotion

    New Member

  • Member
  • Pip
  • 1 posts
Same problem here.


Random

Anyone? Bump

Attached Thumbnails

  • Strangefirefox.png

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP