Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Msgsrv32.exe (Not Responding)

  • Please log in to reply




  • Member
  • PipPip
  • 57 posts
Just completed a long, but successful, MALWARE removal with the help of Efwis. Shortly after that (with a day or so), I began to have intermittent problems with my computer not responding or booting up properly. When I pressed CTRL-ALT-DEL, the culprit was a "Msgsrv32.dll (not responding)" msg in the Close Programs window. Intially, ending the task 'solved' the problem, but now I can't get past the screen asking for my password during boot-up (I've had that feature since installing 98 last year). Updates are current. Went to the MS support website, but I guess my machine doesn't support APM because NONE of the options listed for disabling/changing the power management settings show up when I get to them. I tried extracting msgsrv32.exe from the original .cab files, but that didn't fix the problem. Ran the msconfig options AND sfc, no help. I can get into SAFE MODE, but that doesn't help me with accessing the internet. Here's some info on the POWER MANAGEMENT screens. Let me know if you need anything else.

Just tried to extract the file - no joy. Here's what I see when I double-click on 'Power Management' in control panel:

Window with two tabs: "Power Schemes" & "Advanced"

Under "Power Schemes", my only option is a drop down box titled 'Power Schemes'. When I open the box, my three options are, "Home/Office Desk", "Portable/Laptop", and "Always On". I changed it to the first one, but it was originally "Always On". After selecting a scheme, your only choices are to 'Save As..." or "Delete".

Under "Advanced", the only option is a check-box that says "Always show icon on the taskbar." It is unchecked.

When I expand the "System Devices" tab in "Device Manager" after d-c'ing "System" in control panel, my options are (NOTE: This is in SAFE MODE. The options are different in normal mode, but I can't get into normal mode and don't remember the differences):

ACPI IRQ Holder for PCI IRQ Steering
ACPI IRQ Holder for PCI IRQ Steering
ACPI IRQ Holder for PCI IRQ Steering
ACPI IRQ Holder for PCI IRQ Steering
ACPI Power Button
ACPI System Button
Composite Power Source
Direct memory access controller
IO read data port for ISA Plug and Play enumerator
Motherboard resources
Numeric data processor
Plug and Play Software Device Enumerator
Processor support
Programmable interrupt controller
SCI IRQ used by ACPI bus
System board
System board extension for ACPI BIOS
System CMOS/real time clock
System speaker
System timer
VIA Tech CPU to ACP Controller
VIA Tech Standard CPU to PCI Bridge
VIA Tech VT82C686 PCI to ISA bridge
VIA Tech VT82C686 Power Management Controller

I'm about ready to reformat. Can you talk me down from the ledge?

  • 0




    Retired Staff

  • Retired Staff
  • 11,365 posts
errors in Msgsrv32 usually are not errors with that function, but with something that message server is waiting for....message server is like a cop at an intersection waving his hand at a car to move forward, but the driver is too busy fiddling with the radio.

So, let's now concern ourselves with that at the moment.

When you get the password screen, you say you cannot get past it...meaning...what?
  • 0




  • Topic Starter
  • Member
  • PipPip
  • 57 posts

Sorry about the late reply - it was a LONG weekend. Still working on transferring files.

As for the password screen, what happens is that the computer stops responding. To use your analogy, the 'traffic cop' must be looking the other way, shining his whistle, or eating a doughnut because the cursor alternates between an arrow and an hourglass. When I get to the point of putting in the password, my typing goes faster than the *'s appear to indicate entering of a character. I'm I so bold as to click "Enter" after that, nothing happens. No matter how long I wait (and I've waited for 20-30 minutes to see if it would process), nothing happens. After either course (not putting in a password or clicking "Enter" after doing so), if I press CTRL-ALT-DEL, I see the 'Msgsrv.32 (not responding)' error in the "Close Programs" window.

  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP