Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Computer wont turn on..please help


  • Please log in to reply

#1
sikkasill

sikkasill

    New Member

  • Member
  • Pip
  • 2 posts
Hello, I built a brand new computer and things were working fine at first. I was getting BSOD's occasionally though. One day i went to go on the internet and the computer just shut off. I tried turning it back on and it would boot for a second, then turn off. It shows the power light and makes a click noise but doesnt turn on and boot. I thought something happened to the power supply so i returned it and received a NEW one. I put it in yesterday but it STILL does not turn on... no fans start up or anything, just the power button flashes for a quick second. The motherboard has two lights on it when i have the cpu, motherboard and 1 stick of ram plugged in, which the colors are blue led and yellow led. I dont know what to do or how to find out whats wrong with what... Its not the power supply, but maybe the MB itself?

Things i have tried:
1) Replaced the psu and got a brand new one, and still nothing. So its not the power supply
2) Unplugged everything and then plugged in the cpu, motherboard and 1 stick of ram
3) Checked the MB manual for that yellow LED but i cant find out what it means
4) Changed sockets and changed the power cord itself
5) Tried no ram at all to see if an error beep would come up, but it doesnt even boot long enough to do that. It barely turns on..

My Specs Are:
Motherboard - Nvidia 780i
Power Supply - Antec 650W
Ram - two 2gb Gskill DDR2
CPU - Q6600
Gfx - 9800gtx

Edited by sikkasill, 21 January 2009 - 12:44 PM.

  • 0

Advertisements


#2
sikkasill

sikkasill

    New Member

  • Topic Starter
  • Member
  • Pip
  • 2 posts
Unless ive recieved ANOTHER dead psu? is that possible.. when i flip the switch no fans move on anything, but when i press power button it moves for a quick second

Edited by sikkasill, 21 January 2009 - 01:11 PM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP