Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Java works in IE, not in Firefox


  • Please log in to reply

#1
sweetdave

sweetdave

    Member

  • Member
  • PipPip
  • 86 posts
Java and me - sighs

I have moved to a new computer - Vista 64bit Ultimate.

I have downloaded Java - and IE confirms I have the right version - v6 update 11 - and the 'dancing duke' figure appears all hunky-dory.

Firefox, tho - fails to recognise Java - no 'duke' !!

As I'd prefer to use Firefox as my main browser, I'd like to get Java to work with it.

I've tried the suggested fixes, clearing cache, etc - seems not to make any difference.

Any ideas, please?
  • 0

Advertisements


#2
Major Payne

Major Payne

    Retired Staff

  • Retired Staff
  • 5,307 posts
Is the boxed checked for Java under Tools>Options>Content tab? FF3?
  • 0

#3
sweetdave

sweetdave

    Member

  • Topic Starter
  • Member
  • PipPip
  • 86 posts
Thanks for replying

Yes, under Tools/Options/Content there are ticks against both 'Enable Java script' and 'Enable Java'

Under 'Advanced' for 'Enable Java script' there are ticks against 'Move or resize windows' and 'Disable or replace context menus'

:)
  • 0

#4
Major Payne

Major Payne

    Retired Staff

  • Retired Staff
  • 5,307 posts
Which version of Firefox and have you tried running Firefox in its Safe Mode (NOT Windows Safe Mode)?
  • 0

#5
sweetdave

sweetdave

    Member

  • Topic Starter
  • Member
  • PipPip
  • 86 posts
Firefox Version - "Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5" (copy/pasted from Firefox 'Help/About Firefox'

Restarted in Safe Mode - went to Java site - 'How do I test whether Java is working' - no 'Dancing Duke' logo - and the 'Verify Java Version - Detecting Java on your computer' - the little thingummy keeps rotating endlessly

Seems Firefox can't see Java on the puter :)
  • 0

#6
sweetdave

sweetdave

    Member

  • Topic Starter
  • Member
  • PipPip
  • 86 posts
Dunno if it's relevant, but ....

I have a new computer, and a new Operating System which i am finding my way round.

Just looked at Control Panel Home/Additional Options/View 32bit Control Panel Items - which shows Java as one of the items.

I have Vista 64 bit - is the diff between 32 bit and 64 bit the cause of the problem? Mebbe IE can handle it, Firefox
can't?
  • 0

#7
Major Payne

Major Payne

    Retired Staff

  • Retired Staff
  • 5,307 posts
I have a Vista 64-bit machine and not having any problems with Firefox and Java so that is not you problem I would imagine. When you downloaded Jave, you were in IE I believe. Try downloading Java while in Firefox.

Java Downloads for All Operating Systems
Verify Java Version

Edited by Major Payne, 24 January 2009 - 08:12 PM.

  • 0

#8
sweetdave

sweetdave

    Member

  • Topic Starter
  • Member
  • PipPip
  • 86 posts
OK - re-installed Java through Firefox. It told me I already had Java (even tho I was downloading through Firefox, which doesn't recognise Java!). It first uninstalled, then re-installed.

Came out of Firefox, and re-loaded it

Incidentally, checked Tools/Options/Content in Firefox.

Against 'Enable Java SCript' clicked 'Advanced' - and ticked all the boxes in the next dialogue panel.

Java still works in IE, doesn't in Firefox. :)
  • 0

#9
Major Payne

Major Payne

    Retired Staff

  • Retired Staff
  • 5,307 posts
We are not getting Java and JavaScript mixed up here are we?
  • 0

#10
sweetdave

sweetdave

    Member

  • Topic Starter
  • Member
  • PipPip
  • 86 posts
I hope not - tho I would class myself as a naive user. I don't know exactly what Java and JavaScript are, in detail - and the 'Java' bit seemed to me to indicate there might be some connection.

When I went to Tools/Options/Content I verified that 'Enable Java' was ticked.

I reported that 'Enable Javascript' was also ticked - in case that was relevant. I didn't touch the 'JavaScript' setttings.

Sorry if I muddied the waters
  • 0

Advertisements


#11
Major Payne

Major Payne

    Retired Staff

  • Retired Staff
  • 5,307 posts
Maybe this is related or will help:

Java applets in Firefox
Java
Java plug-in detected jre collision applet FIXED works Ok!!
Configuring Java (Just in case you missed something)

This is the page I used for testing: TEST PAGE

If we don't get anywhere with this, I'll ask another tech to help out. Any security program, Tool Bar installs/add-ons in FireFox? Tried Safe Mode (NOT Windows Safe Mode)?
  • 0

#12
sweetdave

sweetdave

    Member

  • Topic Starter
  • Member
  • PipPip
  • 86 posts
I looked through the references you gave.

Everything seems to conform Firefox doesn't know about Java - until :-
http://gmal.dk/browserspy - which reports :-

Java enabled Yes
Java supported Yes - version 1.6.0_11
Java version Yes - version 1.6.0_07, 1.6.0_11
Java using object and applet tag
Java using the applet tag

There are no entries opposite the last two lines

The item that refers to http://forums.mozill...ic.php?t=583520 baffles me - I don't understand it - wonder if it might be relevant. If it comes to removing plugins I'd need talking through the procedure.

I don't have ZoneAlarm, NoScript or Adblock. I do have the Yahoo toolbar.

Configuring Jave - yes, both IE and Mozilla Family are ticked - tho the Microsoft Internet Explorer entry is grey-ed out (?)

And yes, I used the same TEST PAGE as you.

-----------

Having worked through your reply so far, I'll send this email, and try Firefox Safe Mode wafer I've closed down, and reopened Firefox in Safe Mode. If the situation changes (i.e. Java is recognised) I'll add another reply.
  • 0

#13
sweetdave

sweetdave

    Member

  • Topic Starter
  • Member
  • PipPip
  • 86 posts
I've looked all through the Mozilla folder, in Programs - don't see a "Mozilla Firefox (Safe Mode) shortcut anywhere in it (nor any reference to 'Safe Mode'.
  • 0

#14
sweetdave

sweetdave

    Member

  • Topic Starter
  • Member
  • PipPip
  • 86 posts
Just to tell you i'll not be around for 3 or 4 days - hospital - but i'll hope to pick up the threads of this problem later - thanks for your help so far :)
  • 0

#15
Major Payne

Major Payne

    Retired Staff

  • Retired Staff
  • 5,307 posts

I've looked all through the Mozilla folder, in Programs - don't see a "Mozilla Firefox (Safe Mode) shortcut anywhere in it (nor any reference to 'Safe Mode'.

Re-read the Safe Mode link. It explains how to enter FF's Safe Mode if it is missing. You might remove or dis-able Yahoo toolbar, too.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP