Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

External drive is inaccessible

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
One of my external hard drives is inaccessible.

I do a lot with audio and need a huge amount of space to store classical music .wav audio files

This data is irreplaceable and I am very concerned about the danger of losing it.

My D: internal data partition is not used for audio storage or use as it is too small. I therefore use a Maxtor 1.5TB external USB hard drive (F: drive) to store all the audio files and the database.

To back this up I have another Maxtor 1.5TB external USB hard drive (G: drive).

This system has worked fine for some time, but about 5 weeks ago the G: drive suddenly and without warning said it could not find any data - I rebooted and it returned. I have since reinstalled the OS (three weeks ago) with all up to date drivers and I have not had that problem again (at least with the G: drive).

This morning the F: drive went silly. Soon after starting, I got a message saying that F: was not formatted and did I want to format it? That is not a good message to get when you know that there is over 350GB of data there. I rebooted and the F: drive was working fine again (somewhat unnerving though).

I had already decided to back up the back up drive with yet another drive and I had already ordered another Maxtor 1.5TB drive (J: drive). As it so happens, the new drive arrived this morning. (I already had a third small external drive attached - which had worked fine - so I removed that). I plugged in the new big one and changed the drive letter to J; I could access the drive fine. Everything looked great so I started the backup on to the new J: drive (which I knew would take a very very long time).

The backup of the G: drive onto the J: drive started fine (my usual backup program) and had copied over some 100 files when it just stopped. I was told that the new J: drive could not be accessed. On investigation it turned out that the drive letters had all been scrambled and I was told that the new drive was now called the "H: drive" and that it was not formatted; did I want to format it? (Incidentally the F: and G: drive letters had all been changed too.)

I have rebooted several times but the J: drive remains inaccessible, and "unformatted" which I know is not so. It never retains the drive letter I keep on giving it, but goes back to the windows default of H: I can see it fine in My Computer but I cannot access it. "Unformatted"

I have asked the supplier here in the UK (Maplin - who are huge in the UK and good) and they tell me that they have not heard of any problems with these Maxtor 1.5TB external drives and I trust them (although I have never ever had this sort of trouble with any of the many other external drives I have had over the years). At one time or another I seem to have had a problem with each of these big drives - all telling me they have no accessible data. Maplin have offered to take the drive back but I do not think it is a mechanical problem, so the problem may just happen again.

I am stuck with a new 1.5TB drive (which I think is mechanically fine, but of course I may be wrong) which will not work.

I saw your site when I was researching spyware and thought you were very helpful with a guy, so I remembered your site in case I ever had a problem. I now do have a problem!!

I should be so grateful if some kind soul could let me know what the problem is. Am I doing something wrong? Is there a solution? Are these drives simply too large for my system? Could it be a power supply problem?

5 years old Dell 8250
XP Prof: SP3
Windows reinstalled 3 weeks ago, with all the latest drivers.
110 GB internal drive partititioned C: 35GB (with OS and program files) and D: the remainder (data)
Connected to native USB sockets (ie not to hub) F: active, G: as backup and J: (just purchased) as backup of backup !
No other USB connections currently active.
Dell tell me that I have the latest BIOS available for this model and so it is right up to date.
BIOS can cope fine with 3 external hard drives on start up but no more. Anything more (even a hub) and BIOS freezes on boot up. Dell say I have to live with that and I can.
  • 0





  • Member
  • PipPipPip
  • 114 posts
considering the importance of the data I do not recommend ANY recovery attempts by anyone but a professional as they can damage the data even more. I've even seen experienced computer techs screw it up completely and render the data useless.
you can try to do a chkdsk on the drives but since they are coming as not formatted that may not fix your problem.
to do this you go to start>run> type "cmd" press enter, in the new screen that comes up, type "chkdsk :<driveletter> /r" or course replace "<driveletter>" with F or D or whatever the drive is. asside from that there isn't many options that windows has available. you would either have to buy professional software, (some is free) and do it yourself which I DO NOT recommend at all, or go to a pro.

Drive Savers is your best bet, they are VERY pricey and the prices are dynamic depending on your circumstances but they are the best in the business, if you find a computer store that works with them (like the one I'm at) you can get a %10 discount http://www.drivesavers.com/

there are plenty of recovery companies out there but these guys are the best

before you spend $$$ plug em into another comp and make sure you get the same results

data recovery is a risky business there's millions of things that can go wrong and if it's a mechanical failure of the drives (which I would suspect if they are more than 4 years old) then keep in mind that every second they are running, they're deteriorating. ALWAYS think before you click if you attempt your own recovery and read the instructions to the program you use very carefully you want a program that does absolutely no writing to the disk you're recovering from.

if these are USB drives remember it's just a regular old hard drive on the inside that can be removed and used as an internal drive. (NOTE: some manufacturers of external drives make this impossible by implementing hardware level encryption or proprietary file systems that can only be read through the USB although I have done it with seagates before just fine, which is the same company as maxtor) being 1.5T your drive could be a RAID configuration(multiple drives that work together) which comes with a whole plethora of different problems and road blocks (if it is a RAID don't even consider removing the drives from the enclosure).

some good programs I've used are O&O recovery and active partition recovery
if you insist on doing it yourself remember NEVER EVER NEVER NEVER EVER EVAR save recovered data to the same drive you are recovering from until you're absolutely certain you have everything or you run the risk of writing over everything else.

Edited by pr0n, 05 February 2009 - 12:22 AM.

  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP