Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

winlogon, uxtheme.dll and BSOD at shutdown

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
My hard drive crashed about a month ago. It's been replaced and the OS (XP Pro SP3) has been reinstalled along with a lot of other programs.

My issue is that intermittently I get the BSOD at shutdown with the following message:

Stop c000021a {fatal system error} The windows logon process terminated unexpectedly with a status of 0xc0000005 (0x00000000 0x00000000) The system has been shut down.

Then I have to hard shut it down. When I restart I get a winlogon.exe error but it starts up fine anyway. When I check the event viewer it says...

Event Type: Error
Event Source: Application Error
Event Category: (100)
Event ID: 1000
Date: 2/11/2009
Time: 7:21:35 PM
User: N/A
Computer: Home
Faulting application , version, faulting module uxtheme.dll, version 6.0.2900.5512, fault address 0x00001010.

For more information, see Help and Support Center at http://go.microsoft....link/events.asp.
0000: 41 70 70 6c 69 63 61 74 Applicat
0008: 69 6f 6e 20 46 61 69 6c ion Fail
0010: 75 72 65 20 20 20 30 2e ure 0.
0018: 30 2e 30 2e 30 20 69 6e 0.0.0 in
0020: 20 75 78 74 68 65 6d 65 uxtheme
0028: 2e 64 6c 6c 20 36 2e 30 .dll 6.0
0030: 2e 32 39 30 30 2e 35 35 .2900.55
0038: 31 32 20 61 74 20 6f 66 12 at of
0040: 66 73 65 74 20 30 30 30 fset 000
0048: 30 31 30 31 30 01010

I've disabled themes in XP. I've also run sfc /scannow, actually three separate times. At one point, I also replaced the uxtheme.dll. My system runs fine for a few days sometimes and then crashes at shutdown again. I've been trying one thing at a time. The system runs fine for a few days and then BSOD again. I ran DrWatson and found these things...
Application exception occurred:
App: C:\Program Files\Western Digital\Data Lifeguard Tools\DataLifeguard.exe (pid=1124)
When: 1/21/2009 @ 12:53:22.000
Exception number: c0000005 (access violation)
*** ERROR: Symbol file could not be found. Defaulted to export symbols for C:\Program Files\Western Digital\Data Lifeguard Tools\ODIDev.dll -

I ran WinDbg last night but I'm not sure how to use the info that's in it. I'll attach the WinDbg file from last night.

I'm not very experienced in troubleshooting and would appreciate any help. Thanks in advance.

Attached Files

  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP