Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

USB Drive not assigned a drive letter

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
I have a MAXTOR Onetouch4 drive taht I am trying to attach to a Compaq NX6410 running XP SP2. When I plug in the USB cable, I hear the tones of the device being recognized. When I look in My COmputer at the drives, that drive does not show up. When I go to diak manager, the device is ther, but without a drive letter. When I assign the device a drive letter, I can acces the drive from Disk Manager and the Backup software discovers the drive and is able to back up the files requested. Yet when I go to My Computer, the device is still not there. When I reboot the PC, the drive mapping for the MAXTOR drive goes away. If I try to run add new hardware, I get a message that says a hardware discovery is already in progress and that I can't run 2. I've tried several things so far with no luck. Any suggestions??
  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP