Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Firefox "Not Responding", Process keeps going after Closing

  • Please log in to reply




  • Member
  • PipPip
  • 20 posts

Ive recently went ahead and posted in the Malware Removal section of the forum and received plenty of help, in fact my PC is running better, but still not 100%. The Mod there advised me to post here so see if anyone can help me with the rest of my problems. Here is a link to that thread:

Malware Thread

So here is the problem that Im still having:

Whenever I open Mozilla Firefox to surf the internet, it takes a few moments to open up then once the window is open its completely white and at the top it gives me the "Not Responding" message. After a few moments it'll kick in and my homepage will load up. Also, sometimes while browsing the internet, while pages are loading...the "Not Responding" message appears again for a few moments..then it starts to respond again. Happens almost everytime I try to switch between tabs also.

The other thing is that when I close Mozilla Firefox for whatever reason....the process remains for a very long time after Ive closed the program...sometimes over an hour. So when I go to re-open the program, I get the message telling me that a process for firefox.exe is already running, please close it to open another. To which I have to open the task manager and close the firefox.exe process before I can even re-open the browser.

Lastly(I feel this is all connected, possibly) Almost every program I run takes a few to start up, seems to run alittle slower than before also....yet if Im steady using whatever program...it tends to work normally after a few so long as Im continually using the program. With the exception of the "Not Responding" that happens while switching tabs on Firefox.

I apologize in advance if this isnt the thread I should have posted in, just going on the advice given to me. So if this isnt the right thread for some reason, please point me in the right direction.

Thank You for any help in clearing up this matter with my PC.
  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP