Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Connecting to router problem


  • Please log in to reply

#1
rainmaker

rainmaker

    Member

  • Member
  • PipPip
  • 34 posts
Hello and thanks in advance for the help.

First off I have read and searched around including these two threads...

http://www.geekstogo...-....html&st=15

http://www.geekstogo...ty-t210691.html

And have tried the usual fix attempts to no avail. The problem is I can not connect my XP machines wirelessly to my router when security of any kind is enabled. I.e. if I disable the network security in my router (D-Link DIR-655) I can connect, but if I set any of the variations (WEP, WPA, etc.) the XP machines will not connect. However, the Linux machine will connect regardless. And the XP machines will connect just fine with a cable.

Any help would be greatly appreciated.

~RainMaker
  • 0

Advertisements


#2
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
Howdy RainMaker,

Have you updated your network adapter drivers to the latest version? This is the most likely cause. Are you using third party software to handle your wireless connection, or WZC?

Please follow the steps listed in this MS Article - Wireless Connection Is Periodically Lost -- I'm mainly interested in Part 1: Disable IEEE 802.1X Authentication. Once you have authentication disabled, try connecting to the router again; what happens?

If you still can't connect, can you please do the following twice -- once when encryption is disabled, and the second time when it is enabled.
*Note: Make sure you post the contents of the text file before running the command the second time, else it will simply overwrite it.
  • Click Start, select Run, type cmd and press OK
  • In the new command prompt window, type ipconfig /all > C:\ipconfig.txt
  • Navigate to your C: drive and open the text file ipconfig.txt -- please copy/paste the contents of this file into your next response.
Thanks,
- Dan
  • 0

#3
rainmaker

rainmaker

    Member

  • Topic Starter
  • Member
  • PipPip
  • 34 posts
Okeedokee...

The IEEE box is unchecked.
Results of ipconfig/all with WPA-Personal enabled on router (and yes I double checked the passkey)


Windows IP Configuration

Host Name . . . . . . . . . . . . : pinky
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Broadcast
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Description . . . . . . . . . . . : Intel® PRO/100 VE Network Connection
Physical Address. . . . . . . . . : 00-09-6B-82-7B-E7

Ethernet adapter Wireless Network Connection:
Media State . . . . . . . . . . . : Media disconnected
Description . . . . . . . . . . . : D-Link AirPlus Xtreme G DWL-G650 Adapter
Physical Address. . . . . . . . . : 00-11-95-04-C9-D6


And the results connected with no security on the router...

Windows IP Configuration

Host Name . . . . . . . . . . . . : pinky
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : Metaverse

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Description . . . . . . . . . . . : Intel® PRO/100 VE Network Connection
Physical Address. . . . . . . . . : 00-09-6B-82-7B-E7

Ethernet adapter Wireless Network Connection:

Connection-specific DNS Suffix . : Metaverse
Description . . . . . . . . . . . : D-Link AirPlus Xtreme G DWL-G650 Adapter
Physical Address. . . . . . . . . : 00-11-95-04-C9-D6
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.0.198
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.0.1
DHCP Server . . . . . . . . . . . : 192.168.0.1
DNS Servers . . . . . . . . . . . : 192.168.0.1
Lease Obtained. . . . . . . . . . : Saturday, March 07, 2009 2:30:27 PM
Lease Expires . . . . . . . . . . : Sunday, March 08, 2009 2:30:27 PM

Thanks,

~RainMaker
  • 0

#4
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
Hm, yes you definitely aren't getting any sort of connectivity. I'm surprised that even WEP doesn't work; are you typing in the HEX key when using WEP?

Are you using the same adapter in both XP machines? Have you downloaded and installed the latest driver version?

An issue connecting to WPA/WPA2 encryption usually means your adapter either doesn't support it, or you don't have the latest drivers; however WEP should be accessible to all wireless adapters.

One thing I would suggest would be to remove the wireless profile associated with your network, and start from scratch -- attempt to use WEP for now. Often times if you mistype a key, it can remain in your settings, stored incorrectly even if you re-type it correctly at a later date.

Step 1 - Remove your wireless profile:
  • Click Start, select Run, type ncpa.cpl and press OK
  • In the new window, right-click on your Wireless Network Connection and select Properties.
  • Select the Wireless Networks tab.
  • Click on your network's SSID and then press the Remove button.
Step 2 - Re-install your network adapter:
Please do the following -- *Note: You may need your Network adapter drivers CD in order to complete these steps.
  • Click Start, select Run, type devmgmt.msc and press OK
  • In the Device Manager, expand Network adapters
  • Under Network adapters, right-click your network adapter and select Uninstall.
  • Restart your computer; upon reboot, Windows will detect New Hardware and ask you to install your network adapter; please proceed to do so.
Step 3 - Update your adapter to the latest driver version:
Please ensure that you have downloaded the latest drivers from your manufacturers website.

Step 4 - Attempt to setup your network connection:
Try to connect to your network using WEP; ensure you type the key correctly.

- Dan
  • 0

#5
rainmaker

rainmaker

    Member

  • Topic Starter
  • Member
  • PipPip
  • 34 posts
Thanks for the help Dan. I thought I'd let you know how this worked out. Before your last message I thought I might try a different wireless network card...so I did and it worked. Then I thought I'd try the old one again and run through the steps in the last message. So I threw the old one in...lo and behold it works now too! I didn't do a thing but install the driver for the other adapter (both are D-Link but too different models for whatever that's worth). Very odd, but it's all working now.

Thanks again.

~RainMaker
  • 0

#6
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
Glad to hear you managed to get things working, RainMaker. Thanks for taking the time to let me know -- feedback is always appreciated :)
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP