Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Iomega ScreenPlay Multimedia Drive USB 2.0/AV 60gbs


  • Please log in to reply

#1
snitchy

snitchy

    New Member

  • Member
  • Pip
  • 1 posts
RE: Iomega ScreenPlay Multimedia USB 2.0/AV 60gbs
Computer: Mac: OS X 10.4.11
The problem. When Iomega is connected via USB2 ( as it always has been) it now does not appear in the Desktop nor in the Disk Utility window. If the unit is connected when Disk utility is opened not even the MAC HD appears. The 'wheel' turns and the message is 'Gathering Disk Information'. If the Iomega USB is then disconnected the Disk utility finds the various drives (except of course the Iomega) as per normal. Just before the problem started I was downloading files ant there was a power cut.

Any help would be appreciated as to whether it is possible to reformat or erase the Iomega hard disk without disk utility as I think this would resolve the problem.

Thanks
Snitchy
  • 0

Advertisements







Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP