Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Need Help On Background Intelligent Transfer Service


  • This topic is locked This topic is locked

#1
tw0409

tw0409

    Member

  • Member
  • PipPip
  • 16 posts
I run my google updater and it tells me to start the BITS. And then I start BITS in services.msc and it gives my an error 2 "cannot find specified files".
I read others' problem in this forum and follow the instruction to change the value of ImagePath from %fystemRoot%\system32\svchost.exe -k netsvcs to
%SystemRoot%\system32\svchost.exe -k netsvcs in three places

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\BITS

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002

in all three places, when I edit the values, i get "Cannot edit ImagePath: error occurs when edit in new value."

I also download the regtool.vbs and run it to enable or disable Registry Editing tools. I get "Cannot edit ImagePath: error occurs when edit in new value" in both situations.

How can I do to fix the BITS

Thanks! :)

Edited by tw0409, 14 March 2009 - 04:18 PM.

  • 0

Advertisements


#2
Rorschach112

Rorschach112

    Ralphie

  • Retired Staff
  • 47,710 posts
Please go to the malware forum and follow the instructions at the top....Especially the CLICK HERE.

That will give you several steps that will help you clean up 70 percent of all problems by yourself. If at the end of the process you are still having difficulty--and you may not be-- then post a hijackthis log in THAT forum.
  • 0

#3
tw0409

tw0409

    Member

  • Topic Starter
  • Member
  • PipPip
  • 16 posts
Hello
I follow the steps up to the one that tells me to do Windows update...
BITS is required to perform the updates.

BTW I did have some malware and trojans removed from my computer :)
but the BITS is still unable to start. I don't think it's caused by spyware or virus.
  • 0

#4
Rorschach112

Rorschach112

    Ralphie

  • Retired Staff
  • 47,710 posts
It is

Do the other steps
  • 0

#5
tw0409

tw0409

    Member

  • Topic Starter
  • Member
  • PipPip
  • 16 posts
Here are my hijack this log, OTListIt log and rooter log
note that there are several Chinese characters that you may not be able to see
I skim through them and find the entries with Chinese characters are not suspicious...

Thanks
  • 0

#6
Rorschach112

Rorschach112

    Ralphie

  • Retired Staff
  • 47,710 posts
Please follow my instructions and post the logs in the Malware Removal forum
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP