Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

WMP11 won't play DRM-protected files. How to change the group poli


  • Please log in to reply

#1
MachFront

MachFront

    Member

  • Member
  • PipPip
  • 10 posts
Hello! :)

I bought a (legit) wmv. and it ends up being DRM-protected. Of course it won't play with VLC and when I opened it with WMP was when I discovered what was going on. (I've never dealt with DRM before at all.)
WMP was unable to connect to download the file's license. (I assume from my reading that's what it needs to do.)

The error message I get is:
The Windows Media Digital Rights Management system cannot perform the requested action because your computer or network administrator has enabled the group policy Prevent Windows Media DRM Internet Access. For assistance, contact your administrator.

I am the administrator for my machine!

I go here and the button is greyed out:
http://drmlicense.on.../en/indivit.asp

I go into Tools>Options>Privacy in WMP and I can't select the check boxes related to "Display Media information from the internet" and "update music files by retrieving media info from the internet" because they're also greyed out.

Did I turn off a service related to this? If so, which? Or... is it something else?
Help!

Thanks.
  • 0

Advertisements


#2
RandomGuy#2

RandomGuy#2

    New Member

  • Member
  • Pip
  • 1 posts
try this as it worked for me: (posting over a year later as I ran into this problem this week and this was the first hit)

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\WMD RM\DisableOnline set to 0

mine was set to 1 (enable), and I kept getting the same errors changing to o caused everything to work. silly M$.

Edited by RandomGuy#2, 19 July 2010 - 05:10 PM.

  • 0

#3
crasher

crasher

    New Member

  • Member
  • Pip
  • 1 posts

try this as it worked for me: (posting over a year later as I ran into this problem this week and this was the first hit)

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\WMD RM\DisableOnline set to 0

mine was set to 1 (enable), and I kept getting the same errors changing to o caused everything to work. silly M$.


I can't thank you enough for this answer.
I owe you an internet sixpack of the beer of your choice.
  • 0

#4
nikkidreamer

nikkidreamer

    New Member

  • Member
  • Pip
  • 1 posts
Yay! I'm a somewhat intermediate level computer user and I couldn't get the library's program for e-books to work. this key change shook something loose that let the computer update the security download and use the files legit! Thanks so much for the help!!!
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP