Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Can't restore WinXP after failed mem upgrade


  • Please log in to reply

#46
BrooklineTom

BrooklineTom

    Member

  • Topic Starter
  • Member
  • PipPip
  • 31 posts
I finally got the system working over the weekend, without needing help from Tony.

It turns out that the ribbon cable and power for the floppy drive *must* be connected to the motherboard in order for the install/boot process to run correctly. Go figure. The floppy drive hasn't worked for years. When I installed the second hard drive, I took out the floppy and cloned the old drive onto the new one, and everything ran fine. Then the memory failure corrupted the HD, and we went through the saga documented here.

Over the weekend, I decided to try installing Ubuntu instead of windows. Everything seemed to install from the Ubuntu CD just fine, and when I attempted to boot the newly installed system, I got screenloads of error messages as it attempted to boot up.

I shut the system down, swapped the RAM sticks (interchanging slot 1 and slot 2), reseated all the ribbon cables and power connections -- and put the floppy drive back into the system and connected its data and power cables. Maybe there's a loose or broken wire in one of the ribbon cables, and jiggling it around caused it to make contact again. Maybe a connector wasn't seated properly. I think the most likely answer, though, is that the HW *really* wants that HD connected. I notice that green light on the floppy stays on all the time, even though nothing's in it.

When I re-installed Ubuntu -- BINGO! Everything worked as advertised.

Today, the 2 sticks of compatible RAM arrived. I held my breath (and my radiator), swapped out the old sticks and plugged in the new, and restarted -- BINGO! Everything worked, and worked with 2G of RAM instead of 512M.

This afternoon, I reformatted both hard drives (using diskpart on the recovery CD downloaded from here) and reinstalled WinXP from the Powerspec recovery CDs. When I attempted to reboot -- "Error loading OS". I used "fixboot", with no joy. I ran chkdsk /r, it ran to completion and found no errors.

So ... I re-installed Ubuntu, formatted all 560G as linux partitions, and it's been working great since. The system is more responsive than it's ever been.

Thanks for all your help.
  • 0

Advertisements







Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP