Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

new pc

  • Please log in to reply




  • Member
  • PipPip
  • 36 posts
just built a new computer to improve my fps in games i mostly play world of warcraft. after getting the new rig goin with all the drivers installed i'm getting the same fps as my old rig. I"m in the process of trying to see if there are new drivers available will post results but in the mean time could there be another issue. framerate in major cities is 15fps everything maxed out.....drop everything to minimum settings and i still only get 80-90 i know thats not too bad but i should be getting that with settings at least on high with this build i would think.

system specs
amd phenom II quad core 2.6ghz
4gb (2gbx2) ocz 1333mhz ddr3
2 radeon 4870's in xfire
320gb wd caviar sata 3.0
  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP