Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works


  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
Hi There

I am at my witts end and putting in a big call for help!

I run windows XP home edition SP3 on my Dell 2400 Dimenson. About 6 months ago, when i went to add any new usb device (Memory Stick, Camara, Controller ect) I get the "cannot install device, data is invalid message".

The USB devices that i installed prior to this still work fine, in all 4 USB hubs.

I thought i had sussed it the other night by changing the permission settings in reg key edit, as i managed to conect my new mobile phone to the PC, Sucess i thought!

Today i have a new USB flash drive, and i am getting the same message again. I have re installed all of the device drivers for the PC, but cant think of anything else????

I am crying out for help here, so if anyone knows of a solution, please please give me a shout, and i will be forever in your debt!
  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP