Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Crysis Warhead Problem


  • Please log in to reply

#1
Drumbum667

Drumbum667

    Member

  • Member
  • PipPipPip
  • 546 posts
Im having a problem running Crysis Warhead. I did a system requirements lab test and I pass everything, most things at recommended. But whenever I install the game something always goes wrong. Either I open it and it doesnt load the level, and then I get an error about an IntelLaptopGaming.dll. I have a ATI HD 4890, an E6750, and 4 GBs of RAM. I dont think it has anything to do with my hardware but I really would like to run this game.
  • 0

Advertisements


#2
mpascal

mpascal

    Math Nerd

  • Retired Staff
  • 3,644 posts
What operating system are you using? I recommend you download the latest patch for the game and see if the problem persists.
  • 0

#3
Drumbum667

Drumbum667

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 546 posts
Im on Vista. Ill reinstall and try updating it.
  • 0

#4
ZEUS_GB

ZEUS_GB

    There's no school like old school!

  • Retired Staff
  • 1,650 posts
Hi Drumbum667,

Have you got the latest Crysis Warhead patch installed?

Did the installation go ok? installation error messages? Did it install Visual C++ 2005 Redistributable and DirectX?

Have you tried reinstalling it?
  • 0

#5
Drumbum667

Drumbum667

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 546 posts
No errors, but it did not install Visual C++ Redistributable, should i install that myself.
  • 0

#6
Drumbum667

Drumbum667

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 546 posts
I reinstalled, installed the visual c++, updated DX10, installed both patches. And now I get passed the loading bar, but it hangs when i click the button to start the level.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP