Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Where's my globe gone?

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
Not a problem as such but annoying as I can't work it out.

I'm connected to the internet (obviously as I'm here :) ) but on my icon I have a red cross and not the globe, any idea's how to get my globe back?

Thanks in advance and appologies if this is posted in the wrong section.

  • 0





  • Member
  • PipPipPip
  • 431 posts
Hello Annie and welcome to Geeks To Go. I have not experienced this personally, but have heard others having this problem. A couple things you can try are below:

  • Run Windows Update until Vista is FULLY updated
  • Uninstall AIM & Reinstall the Newest Version
  • Unplug your network cable and plug it back in

Also, it may just be you have multiple adapters in which one isn't plugged in. You should be able to click the properties of it and somewhere in there is the option to display/hide on the taskbar. Let me know if any of the above helps.
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP