Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Keyboard Repeat Rate & Regional and Language Options


  • Please log in to reply

#1
vnbomber9

vnbomber9

    Member

  • Member
  • PipPip
  • 17 posts
Short description:
Keyboard Repeat Rate & Location in "Regional and Language Options" keep getting reset everytime I start my computer up.

Long description:
I have been using Kaspersky Antivirus up until now and I update it quite often, but then I moved and didn't have the chance to update its virus list for around 2 weeks and accidentally got infected with the "gxvxc" virus. I tried to remove it manually like this:
S0. (System restore was automatically disabled by the virus)
S1. Booted into safe mode
S2. Used Unhackme (an anti-rootkit removal tool) to terminate the virus.
S3. Scanned (still in safe mode) for every possible malware using MalwareBytes Anti-Malware, and removed them.
S4. Delete traces of the virus: the fake Recycler, the virus's copies in system32, autorun.inf, in the Registry, startup.
S5. Uninstalled and reinstalled Kaspersky, because the virus somehow succeeded in preventing Kaspersky from running, Kaspersky was still able to start, but could not do a thing, let alone killing the virus. Updated virus list. Did a full scan.
S6. Booted into normal mode, ran Unhackme, Malwarebytes Anti-Malware and Kaspersky again, nothing found. Ran Windows Update (btw, I'm using XP SP2). Everything seemed to be OK.

But THEN:
P1. Keyboard repeat rate gets reset everytime my computer starts up. It's a nuisance having to scroll it back again to max speed.
P2. I can't change the Location and Standard in Regional and Language Options, it resets immediately after closing, for example: I change Location from US to Germany, hit "apply" then "OK", open "Regional and Language Options", it's changed back to US.
P3. Driver for integrated (Conexant) microphone seems to be messed up, sound input volume level is really low and I have to put my mouth (or any other sound emitting device) right next to the mic (I'm using a Lenovo T400) so that the mic can recognize the sound.
P4. Driver for mouse also seems to have been reverted back, but I fixed this already.
P5. I'm not sure about this but I think Windows takes longer to shut down than before, however, it still starts up quite fast, but sometimes hangs (quite rare).
P6. Settings for other applications, eg. Yahoo Messenger also gone, or folder options like "Show hidden files" became unchecked (Only once after being hit by the virus, I set them back)



I think this is a registry problem rather than an active virus, it is quite unlikely that my computer is still infected now that MBAM and Kaspersky are running normally again, however, it is still a possibility.

Many thanks in advance for reading and helping :)

Hiro
  • 0

Advertisements


#2
OpenOutcome

OpenOutcome

    Member

  • Member
  • PipPipPip
  • 640 posts
First of all, I suggest you get your system checked by our malware experts. Who knows - there could definitely be some hidden nasties still lurking around somewhere. Go to the Malware Forum and read the stickies located at the top, especially this one.
The guides will give you several steps that will help you clean up 70 percent of all problems by yourself. Then you can post an OTL log in THAT forum. Be patient, the Malware Forum is a very busy place and a two or three day wait is not unusual. Only after a three day wait may you move to The Waiting Room where you will be on the top of the list to be helped. A three day wait is 72 hours.. Make sure it has been over that amount of time, or your Waiting Room topic will be closed.

If you are still having problems after getting a clean bill of health from the malware expert, please return to this thread.
  • 0

#3
vnbomber9

vnbomber9

    Member

  • Topic Starter
  • Member
  • PipPip
  • 17 posts
Thanks for the reply OpenOutcome :)
Although I've already done the required steps, just with other tools, I'll re-do them again to follow the procedures.
Meanwhile, any suggestions on fixing the registry are very welcome :)
  • 0

#4
OpenOutcome

OpenOutcome

    Member

  • Member
  • PipPipPip
  • 640 posts
I'm currently researching your problem. I'll let you know of anything I find! :)
  • 0

#5
vnbomber9

vnbomber9

    Member

  • Topic Starter
  • Member
  • PipPip
  • 17 posts
Hello Openoutcome, I've tried to scan my computer for infection so many times but it couldn't find a thing and the settings keep getting set back to default every time :)
  • 0

#6
OpenOutcome

OpenOutcome

    Member

  • Member
  • PipPipPip
  • 640 posts
You haven't made a log for the malware staff to look at.. After reading the stickies from the malware forum, copy and paste your OTL log as a new topic in THAT forum.

Download OTL to your Desktop

  • Double click on the icon to run it. Make sure all other windows are closed and to let it run uninterrupted.
  • When the window appears, underneath Output at the top change it to Minimal Output.
  • Click the Run Scan button. Do not change any settings unless otherwise told to do so. The scan wont take long.
o When the scan completes, it will open two notepad windows. OTListIt.Txt and Extras.Txt. These are saved in the same location as OTL.
o Please copy (Edit->Select All, Edit->Copy) the contents of these files, one at a time, and post them if you need to start a new topic.

Make sure you post your topic in the MALWARE FORUM.
  • 0

#7
vnbomber9

vnbomber9

    Member

  • Topic Starter
  • Member
  • PipPip
  • 17 posts
Hello OpenOutcome,

as you suggested, I've done the scans and posted a new thread here: http://www.geekstogo...on-t243169.html

I'm looking forward to hearing from you. Many thanks for helping me :)
  • 0

#8
Rorschach112

Rorschach112

    Ralphie

  • Retired Staff
  • 47,710 posts
Sadly you have me to help you out :)


If I don't fix your problem you can return here and let the techs do it
  • 0

#9
vnbomber9

vnbomber9

    Member

  • Topic Starter
  • Member
  • PipPip
  • 17 posts
Now that I've been through with the malware team with a totally clean result, I'm here again to ask for help from the techs. I've got permission from Rorschach112 :)

So, in short, I initially had 2 main problems:
1. I couldn't change the Location in Regional and Language Options. This has magically been solved without knowing how or why O_o
2. The keyboard repeat rate still gets being reset to default every time I reboot/turn on the computer.

and somehow it now takes longer to start up / shut down than before.

I've tried editing the Registry, changed all KeyboardDelay value to 1 and KeyboardSpeed to 31, but it still doesn't help, when I restart it goes back to normal speed, it's a bit irritating =/


Thanks for reading :)
  • 0

#10
vnbomber9

vnbomber9

    Member

  • Topic Starter
  • Member
  • PipPip
  • 17 posts
Could anyone please help? :)
  • 0

#11
vnbomber9

vnbomber9

    Member

  • Topic Starter
  • Member
  • PipPip
  • 17 posts
2 weeks have passed and I've found nothing that helps :)
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP