Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Is it OK to delete Windows Update Backups?


  • Please log in to reply

#1
epcomics

epcomics

    Member

  • Member
  • PipPip
  • 40 posts
Hello. Is it alright to delete my Windows Update Backups or are these essential. It's 762 MB, so if its alright to clean it I'd like to. Thanks in advance.
  • 0

Advertisements


#2
NeonFx

NeonFx

    Malware Removal Dude

  • Expert
  • 3,793 posts
Hi there :)

If you need the space, then yes, it's perfectly OK to delete the backups. There are several tools that you can use to do this.
Here's one:
Windows Update Remover (make sure you don't "uninstall" updates, and only "remove backup")

You should also try out a program such as ATF Cleaner or CCleaner to remove other unneeded space wasters.
  • 0

#3
rshaffer61

rshaffer61

    Moderator

  • Moderator
  • 34,114 posts
Please download ATF Cleaner by Atribune.
Double-click ATF-Cleaner.exe to run the program.
Under Main choose: Select All
Click the Empty Selected button.
If you use Firefox browserClick Firefox at the top and choose: Select All
Click the Empty Selected button.
NOTE: If you would like to keep your saved passwords, please click No at the prompt.
If you use Opera browserClick Opera at the top and choose: Select All
Click the Empty Selected button.
NOTE: If you would like to keep your saved passwords, please click No at the prompt.
Click Exit on the Main menu to close the program.
For Technical Support, double-click the e-mail address located at the bottom of each menu.

When that is done

Download Auslogics Defrag from the link in my signature below. Auslogics Defrag in my opinion is better because:

It does a more comprehensive job at Defragging
It will actually show you what it is doing
At the end of working it will show you how much speed you picked up
You can view a online log of the files that Auslogics defragged



Reboot and let me know how system is running now
  • 0

#4
epcomics

epcomics

    Member

  • Topic Starter
  • Member
  • PipPip
  • 40 posts
That worked great. Thanks a bunch!
  • 0

#5
rshaffer61

rshaffer61

    Moderator

  • Moderator
  • 34,114 posts
Everything running good for you now?
  • 0

#6
epcomics

epcomics

    Member

  • Topic Starter
  • Member
  • PipPip
  • 40 posts
Actually, my computer keeps having short (5-6 second) "seizures" at which point it freezes. This makes typing online very hard because whatever I type and theirs a seizure it stops writing. This is probably unrelated but I though I'd mention it.
  • 0

#7
rshaffer61

rshaffer61

    Moderator

  • Moderator
  • 34,114 posts
Download Autoruns from the link in my signature below:

1: Extract the Autoruns Zip file contents to a folder.
2: Double-click the "Autoruns.exe".
3: Click on the "Everything" tab
4: Remove any entries that mention "File Not Found" by right-clicking the entry and select Delete.
5: Go to File then to Export As.
6: Save AutoRuns.txt file to know location.
7: Attach to your next reply.
  • 0

#8
epcomics

epcomics

    Member

  • Topic Starter
  • Member
  • PipPip
  • 40 posts
Thanks so much man.

Attached Files


  • 0

#9
rshaffer61

rshaffer61

    Moderator

  • Moderator
  • 34,114 posts
The only thing I see in Autoruns is that you are running two Spyware programs
SuperAntiSpyware and Spyware Terminator
I would suggest one of them should be uninstalled. My pick would be the latter one but that is your choice.
A rule of thumb is to only have one each of the following.

Antivirus
Spyware
Malware
Firewall

I see you are using Avira for AV. Is that working ok for you? If not then i would suggest Avast.
Doesn't use much as far as System Resources. If Avira is working for you then there is no need to change.

I would like to check your Startup Services now. Please follow the next steps to do this:

Please click on
Start and then to Run
Type in msconfig and press Enter
Now click on Services
Click on the Hide All Microsoft Services
Then uncheck everything and restart.
If system boots correctly and is running smoothly and faster then we have a startup problem
Try going back into msconfig and check one item and reboot
Keep doing that till you have found the problem or all are finally checked.
Post back with the results
  • 0

#10
epcomics

epcomics

    Member

  • Topic Starter
  • Member
  • PipPip
  • 40 posts
I uninstalled Spyware Terminator and that seemed to take care of the problem. I still did what you said in the post above this though and it didn't seem to make a difference. Thanks a ton man, it seems to be working fine now.
  • 0

#11
rshaffer61

rshaffer61

    Moderator

  • Moderator
  • 34,114 posts
Thank you for the update. I'm sorry my reply is so long to come to you. I had some business to take care of.
Is everything working ok still now that it has been about 5 hours? If so I would like to say:

Congratulations. :) for a successful resolution for your issue. I am happy everything has been worked out for you. With that being said I am happy to say:


You are very welcome. I'm glad we could help and please let us know how everything works out for you.
If there is anything else we can do to help please feel free to ask. I appreciate that you allowed me to assist you with your issue and for your patience. Thank you for choosing GeeksToGo for help. :) :)
This issue now appears to be resolved.


If other members are reading this and have a similar problem please begin a New Topic and someone will assist you as soon as possible


If you are happy with the service I provided, please consider making a donation to GeeksToGo to support the Free Technical Support offered. Go HERE to make a donation.
  • 0

#12
epcomics

epcomics

    Member

  • Topic Starter
  • Member
  • PipPip
  • 40 posts
Oh yeah the problem is definitly gone. Thanks again for all your help.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP