Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

BITS path changed?


  • Please log in to reply

#1
Neena0

Neena0

    New Member

  • Member
  • Pip
  • 5 posts
OK, here we go.
I bought a Dell 530 from my cousin. She thought it was damaged beyond repair because she had non-stop pop-ups on her desktop and the internet wasn't working. So she did what she thought was 'cleaning it out' witch ended up being just right clicking delete on everything.
I've put in so much time and effort in restoring this thing. But now I've reached a problem I don't think I can handle anymore.

My automatic updates are disabled. And when I tried to switch it over, I get a message saying windows can't do it basically. After a good long runaround I ended up at my services.msc to see if mt BITS was working. It's not. Again, after a lot of research and a runaround, I think the path is faulty. It says %fystemRoot%\system32\svchost.exe -k netsvcs. My understanding is, the 'f' should be a 'S'. I've tried to edit it, to no avail.

Just in case anyone is wondering, I have avast!, ccleaner, malwarebytes, and SUPERAntiSpyware installed to try to fight the loads of issuse this thing had.

Thanks so much!
  • 0

Advertisements


#2
Ectech

Ectech

    Member

  • Member
  • PipPipPip
  • 204 posts
That's an easy fix. :)

First, backup the registry using ERUNT.

Next, click Start > Run > Type: Regedit > click ok.

Navigate to HKEY_Local_Machine\System\CurrentControlSet\Services\BITS

Right click ImagePath > select Modify > change to value to %systemRoot%\system32\svchost.exe -k netsvcs

then exit Regedit and Reboot.
  • 0

#3
Neena0

Neena0

    New Member

  • Topic Starter
  • Member
  • Pip
  • 5 posts
Thanks for the response, but I've tried all that before. It just resets itself into the 'f' instead of the 's' and nothing changes.
I'll try it once more to see if I did anything wrong. But in the meantime, any other ideas to why it's doing this?
Thanks again!
  • 0

#4
diabillic

diabillic

    Member 1K

  • Member
  • PipPipPipPip
  • 1,370 posts
Yes, my question is what exactly is causing the change.

Try editing it in Safe Mode then rebooting back into Safe Mode again to see if it changed. This will eliminate any 3rd party software as the root cause.
  • 0

#5
Ectech

Ectech

    Member

  • Member
  • PipPipPip
  • 204 posts
Your machine is still infected, post a new topic here... http://www.geekstogo...emoval-f37.html
  • 0

#6
Neena0

Neena0

    New Member

  • Topic Starter
  • Member
  • Pip
  • 5 posts
OK, after renaming and rebooting, it seems to have kept the change as far as the BITS path goes, but the path for my automatic updates still has the 'f' in the path name. I did a search in regedit for 'fystemroot' and a few things came up, but nothing that had a path to change like I did with the ImagePath.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP