Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

unknown hardware


  • Please log in to reply

#1
roastmaster

roastmaster

    New Member

  • Member
  • Pip
  • 6 posts
I have two unknown hardware devices in my device manager. DetectAC2000 showed up after I installed Avant or Maxthon. I dont know where ids0004c came from the only thing I can find is in russian? They are both listed in other devices. I dont think I need these do I? I am running XP SP2. :tazz:
  • 0

Advertisements


#2
roastmaster

roastmaster

    New Member

  • Topic Starter
  • Member
  • Pip
  • 6 posts
:tazz: Am I on my own with this problem? ;)
  • 0

#3
austin_o

austin_o

    Retired Staff

  • Retired Staff
  • 2,089 posts
If you don't know what they are and can't find any info on them, and you didn't install them, try deleting them. If they come back, I would bet you have a malware problem.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP