Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Code 47 USB error


  • Please log in to reply

#1
Perplexed1

Perplexed1

    New Member

  • Member
  • Pip
  • 7 posts
I have a HP Media Centre PC which has three USB 2.0 ports on the front which have stopped working. Two of the ports are on the front panel with the audo/mike ports and the third sits above these with the various photo capture ports - compact flash/smart media etc. I have two USB 2.0 ports on the back of the PC which still work.

I've looked at the Device Manager. Under the USB Controllers link I have two separate USB Mass Storage Devices listed, one of which has a yellow exclamation mark against it. The properties for this show "Windows cannot use this hardware device because it has been prepared for "safe removal", but it has not been removed from the computer. (Code 47)".

I've tried uninstalling and reinstalling drivers. When I try to update the drivers I get a message that the wizard can't find a better match than the drivers I have.

I'd appreciate advice on how I can fix this problem.

Thanks all

Anne
  • 0

Advertisements


#2
edge2022

edge2022

    Member 2k

  • Member
  • PipPipPipPipPip
  • 2,117 posts
Can you give me the make and model of your computer?
When did you notice that the ports stopped working? Did you install any new drivers of software? What do you have plugged into your USB ports?
  • 0

#3
Perplexed1

Perplexed1

    New Member

  • Topic Starter
  • Member
  • Pip
  • 7 posts
Hi

My apologies for not being back in touch - have been travelling.

It's a HP Pavilion a1550a. The ports have not been working for some months now. I don't have anything plugged into the front USB ports. I had a Microsoft Optical Mouse running and a Brother Printer running off a couple of these USB ports but they both stopped working about 8 weeks ago. I resorted to a connected mouse instead from one the mouse "port" at the back, can't remember whether it's parallel or serial. The printer is now running on another machine.

I don't recall adding any new drivers or software at the time the problem became noticeable.

Thanks

Anne



I don't recall adding any new hardware
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP