Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Windows XP Log on Menu


  • Please log in to reply

#1
Thuvasa3

Thuvasa3

    Member

  • Member
  • PipPip
  • 11 posts
Hi,

I have the same problem for two computers--one belongs to my in-laws, the other to my uncle.

When they boot up the computers, they get a menu asking which operating system they want to use. How do I get rid of that?

For my uncle, his computer was virus ridden (2000+ viruses when I finally took it home and cleaned it off). Because his system was corrupted, it kept telling him to reinstall. And so he did, creating an additional menu option each time. I installed Win XP on his computer (he had Win 2000). However, because he had all those installations, there is a menu option for each of them (though they no longer work).

My in-laws managed to delete all their drivers (for sound and what not) and reinstalled for that reason. So they also have a multiple choice for operating system.

Is there any way to get rid of that menu w/o formatting the drive?

Thanks!

Jonathan
  • 0

Advertisements


#2
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
Yes, the extra menu is created by a file called boot.ini, which can be opened in notepad, or in by r-clicking MY COMPUTER, choose PROPERTIES, choose ADVANCED, choose STARTUP and RECOVERY, then hit the EDIT button.

To be safe, you really should post the file here or somewhere else and have someone who understands ARC
  • 0

#3
Thuvasa3

Thuvasa3

    Member

  • Topic Starter
  • Member
  • PipPip
  • 11 posts
Thanks! I will do that when I get home. What directory is boot.ini typically in? Also, do you think I will need to post the file for both computers, or will I be able to use the example of how to do one and do both? I ask because my in-laws are truly the most computer clueless people I've ever met (and I've *far* from "savvy"), so I won't be able to get the file w/o going to their house. :tazz:

Thanks for your help!

Jonathan

EDIT: Didn't get the chance to look for it last night. Curses! I will definitely have time tomorrow though! (Wife is going to hang out with her sister).

Edited by Thuvasa3, 13 May 2005 - 06:46 AM.

  • 0

#4
Thuvasa3

Thuvasa3

    Member

  • Topic Starter
  • Member
  • PipPip
  • 11 posts
I'm having some trouble finding the file. What directory will it be in?

J
  • 0

#5
bhmax16

bhmax16

    Member

  • Member
  • PipPip
  • 30 posts
You shouldn't have to search for the file. Simply right click on "my computer" and select "properties." From there click the "advanced" tab then click "Settings" under "Startup and Recovery." This will automatically open the boot.ini file (most likely in notepad). From here look at everything under where it says [operating systems]. It should look something like this...

[operating systems]
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Professional" /fastdetect

If your computer is giving you the screen asking which operating system to startup with it means you have multiple operating systems on the machine (even if they're all Windows XP, they will show up as being different operating systems if you assigned them a different title while fixing the computer). Locate the one that has the title that you normally choose to startup the computer and delete all the other ones. In my case I use the default title, "Microsoft Windows XP Professional" as you can see above in the example I posted. After you do this click out of notepad...you will automatically be asked if you want to save the changed you made, click yes, and you should be good to go next time you restart your computer. If you have any questions let me know
  • 0

#6
Thuvasa3

Thuvasa3

    Member

  • Topic Starter
  • Member
  • PipPip
  • 11 posts
Upon re-reading, I see I should have got that out of the first reply. I get an F for reading comprehension. I'll post the file when I get home today.

Jonathan
  • 0

#7
bhmax16

bhmax16

    Member

  • Member
  • PipPip
  • 30 posts
Sounds good, it's my birthday today but I still plan on being home all day/night. When you post the file I will review it and let you know what to keep and what to get rid of, take care

Bill
  • 0

#8
Thuvasa3

Thuvasa3

    Member

  • Topic Starter
  • Member
  • PipPip
  • 11 posts
At last! There is a sordid tale of a bent case that required some hammering to get the computer put back together, but at last I am here, and have managed to follow the directions and everything. Here is the boot.ini file:

EDIT: For some reason, it's word wrapping when I past it in here. I will try to manually undo it.

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect
signature(a37ea37e)disk(0)rdisk(0)partition(1)\WINNT.1="Microsoft Windows 2000 Professional" /fastdetect
signature(a37ea37e)disk(0)rdisk(0)partition(1)\WINNT.0="Microsoft Windows 2000 Professional" /fastdetect
signature(a37ea37e)disk(0)rdisk(0)partition(1)\WINNT="Microsoft Windows 2000 Professional" /fastdetect


EDIT2: Apparently it's the forum that's doing the wrapping. Anyway to make it not do that?

Edited by Thuvasa3, 17 May 2005 - 04:47 PM.

  • 0

#9
bhmax16

bhmax16

    Member

  • Member
  • PipPip
  • 30 posts
Ok, open the boot.ini file again in notepad...

DELETE:
signature(a37ea37e)disk(0)rdisk(0)partition(1)\WINNT.1="Microsoft Windows 2000 Professional" /fastdetect
signature(a37ea37e)disk(0)rdisk(0)partition(1)\WINNT.0="Microsoft Windows 2000 Professional" /fastdetect
signature(a37ea37e)disk(0)rdisk(0)partition(1)\WINNT="Microsoft Windows 2000 Professional" /fastdetect

KEEP:
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect

Save the file then exit. After doing this you won't be asked which operating system to startup with during bootup. Let me know if it works, but it should

Bill
  • 0

#10
Thuvasa3

Thuvasa3

    Member

  • Topic Starter
  • Member
  • PipPip
  • 11 posts
Fixed! Thanks so much to both of you for your help!

Jonathan
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP