Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Local Only Connection on Ad-Hoc Network


  • Please log in to reply

#1
bake

bake

    Member

  • Member
  • PipPipPip
  • 130 posts
I have two notebooks running Vista. I am trying to set up an ad-hoc wireless network so that I can share my internet connection. I have done this before with these same two notebooks with no problem. However, now the second notebook will connect to my ad-hoc network but I get a local only connection with no internet. I clicked on the red x in the network center but Windows is unable to find a solution. Can anyone give me an idea of what the problem could be?

Thanks
-Bake

Edited by bake, 26 July 2009 - 07:17 PM.

  • 0

Advertisements


#2
Neil Jones

Neil Jones

    Member 5k

  • Member
  • PipPipPipPipPipPipPipPip
  • 8,476 posts
Would it not be easier to buy a wireless router?
  • 0

#3
bake

bake

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 130 posts
Not really, I use my cell phone as a modem and I don't think I could do that with a router.
  • 0

#4
Artellos

Artellos

    Tech Secretary

  • Global Moderator
  • 3,888 posts
Hello Bake,

We're sorry for the very late reply, things can get busy at times :)

You say you can set up the ad-hoc network, but you won't get any internet access.
Does that mean that you -can- access the files of the connected laptops through the network?
If this is the case, then maybe you haven't enabled Internet Connection Sharing?

To enable this, go to your Control Panel and open "Network Connections"
Right click on the network adapter that is being used and select properties.
Go to the advanced tab, and tick the box that says: Allow other network users to connect through this computer's Internet connection

You might need to select what adapter is allowed to connect through your mobile phone.
And you might need to set some settings on what services your second laptop is allowed to use.
(I am not sure if these are requirements as I have not set up an ad-hoc network for quite a while :) )

I hope this information was useful, And sorry once again for the slow response :)

Regards,
Olrik
  • 0

#5
bake

bake

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 130 posts
Hi Artellos,

Thanks for taking the time to reply. Sorry I am late getting back to you.

I found one issue the I had been overlooking. I had Password Protected Sharing enabled that would not allow me to view files and folders on the network. I turned that off and now have Network Discovery, File sharing, Public Folder sharing, Printer sharing, and Media sharing turned on both laptops. They connect on the ad hoc network and the public folders are visible across the network. I tried sharing the internet connection in properties of the modem connection and on the ad-hoc connection. Still no go. I have a Red X between the "Unidentified network" icon and the "Internet Icon". When I click that Windows attempts to find a solution but is unable to fix the issue. Can you think of anything else I could look at. Thanks for any advice.

-Bake

Edited by bake, 12 August 2009 - 01:07 PM.

  • 0

#6
Artellos

Artellos

    Tech Secretary

  • Global Moderator
  • 3,888 posts
Hello bake,

Another thing you can try is bridging the 2 connections. (The incoming and outgoing connections)
If you go to your Network Center to the left there's an option "Manage Network Connections" (or similar)
Open that, then select both network adapters by holding "CTRL"
Then right click and hit "Bridge Connections"

Regards,
Olrik
  • 0

#7
bake

bake

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 130 posts
Hi Artellos,

Thanks again but still no luck. When I choose the two connections and right click I don't get a bridge connections option. I get; Status, Create Shortcut, Delete, Rename and Properties. All of which are grayed out. I have read and followed the guides for sharing an internet connection over an Ad Hoc network over and over. I had these same two laptops working together with no problems several months ago. Matter of fact I was sharing my connection with this and another laptop simultaneously and it worked great. I am really at a loss here.

-Bake
  • 0

#8
Artellos

Artellos

    Tech Secretary

  • Global Moderator
  • 3,888 posts
Hey Bake,

Can you remember anything you chanced since? (Since they -did- work, that is.)

I might pull out some old equipment and do some Ad-Hoc testing to see if I can get it all to work like that.
Lets keep each other updated :)

Regards,
Olrik
  • 0

#9
bake

bake

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 130 posts
Hi Artellos,

I have been racking my brain and I can't think of anything that has been changed other than Firefox and Windows updates. No software added or removed. No hardware changes on either machine. Thanks once again for the thought you have given this issue.

-Bake
  • 0

#10
Artellos

Artellos

    Tech Secretary

  • Global Moderator
  • 3,888 posts
Hey Bake,

The last thing I can think of are the Firewalls.
Aside from that I am out of ideas :)

Regards,
Olrik
  • 0

Advertisements


#11
bake

bake

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 130 posts
Hi Artellos,

Sorry about not getting back to you sooner. I have been searching high and low but I still have found no answer. Just wanted to thank you for the time you put into trying to help me resolve my issue. I think I am going to do a full system recovery and start fresh. I don't know if that will resolve this but I am at a point where I know nothing else to try. Thanks again.

-Bake
  • 0

#12
dianaa

dianaa

    New Member

  • Member
  • Pip
  • 1 posts
did rebooting work? cuss i have the same problem
  • 0

#13
Sneha10s

Sneha10s

    New Member

  • Member
  • Pip
  • 2 posts
Hi there

Have you found a solution yet?
I'm facing a similar problem.
I create an adhoc connection to connect to my iPhone.
Had been easy to connect.
I got a Samsung Galaxy Tab and I tried connecting in the same way.
I changed a few settings in the comand prompt but it was of no use.
Galaxy simply doesn't pair with my lappy.
Since then I've reconfigured my IP address and stuff but now I'm not able to connect to my iPhone.
Any luck with your problem?
  • 0

#14
Sneha10s

Sneha10s

    New Member

  • Member
  • Pip
  • 2 posts
Hi there

Have you found a solution yet?
I'm facing a similar problem.
I create an adhoc connection to connect to my iPhone.
Had been easy to connect.
I got a Samsung Galaxy Tab and I tried connecting in the same way.
I changed a few settings in the comand prompt but it was of no use.
Galaxy simply doesn't pair with my lappy.
Since then I've reconfigured my IP address and stuff but now I'm not able to connect to my iPhone.
Any luck with your problem?
  • 0

#15
Thurein Soe

Thurein Soe

    New Member

  • Member
  • Pip
  • 1 posts
Hey,

Don't do anything. When u setup ad hoc on your laptop, just make sure u leave the IP4 setting to "Obtain IP address automatically". Don't do anything to the IP. But make sure U turn on the internet connection sharing on your main network adapter.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP