Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

W2k8 RDP not listening on the port


  • Please log in to reply

#1
Geeves00

Geeves00

    Member

  • Member
  • PipPip
  • 38 posts
Not sure if this is the right place for server '08 questions (I didn't see any forums for it).....



I have a 2008 EE x64 server that I am having trouble RDPing to.

The error in the event log of the server is:

1048 Terminal Services - Local Session Manager
Terminal Services failed. The Relevant status code was No such interface supported.

The Windows firewall is turned off. NETSTAT -AN shows that the server is not even listening on port 3389.

I checked the local policy and Allow logon through terminal services had the Administrators and Remote Desktop Users. The Logon as service policy item has Network Service included. Note: This is not a term server, just trying to use RDP

The Terminal Services service is set to Auto, it is started, and set to run under Network Services.

Now, I HAVE found a fix for it......but I don't like it. If I add NT AUTHORITY\Network Service to the admin group and reboot, everything works perfectly. The port is listed as listening and I am able to connect remotely.

So this tells me I have a permissions issue somewhere. The question is where. I checked under HKLM\Software\Microsoft\Windows NT\Current Version\SvcHost but the permissions look like my other 2k8 boxes.

Anyone out there have in depth knowledge of how RDP works with the OS to try and determine where the access is being denied?
  • 0

Advertisements


#2
Geeves00

Geeves00

    Member

  • Topic Starter
  • Member
  • PipPip
  • 38 posts
Wow not even a suggestion? I should have known it was an oddball issue when even the guys at experts exchange had no clue lol

Like I said, the fix is there......but, I'm pretty sure it leaves open some pretty big security holes
  • 0

#3
Geeves00

Geeves00

    Member

  • Topic Starter
  • Member
  • PipPip
  • 38 posts
One more bump in hopes someone can help
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP