Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Bios problem

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
I dare say you guys will know the answers, but I am trying to sort out an old ADVENT 3504 that my son has been using, we had it for years, but recently the PSU failed, I took it apart, cleaned it etc and replaced it. It worked ok for a short while then failed completely. I have purchased an identical PSU and installed it but, now have problems. The pc beeps twice. It goes into boot mode but takes to maintenance page in bios set-up utility. Only thing is the keyboard will not respond in order to select. Prior to installing the PSU we had no problems with bios.
My questions are why should this happen (ie we are talking a chip on the board), and what is my solution.
I would appreciate your response.

  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP