Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Yet another hal.dll problem


  • Please log in to reply

#1
MrsHill

MrsHill

    New Member

  • Member
  • Pip
  • 2 posts
Please forgive any archaic terms I use, I have been in unix-land since DOS 6 was the latest thing, and Windows is a bit of a mystery to me...

I have been handed the nephew's Acer Travelmate 4230 laptop.
The licence sticker on the base says the OS is Win XP Pro.
He said "I downloaded some suff... then it did this - nah, can't remember what it was..."
Then showed me a black screen with the dreaded hal.dll error message;
"Windows could not start because the following file is missing or corrupt:
<Windows root>\system32\hal.dll.
Please reinstall a copy of the above file."

Not entirely clear what OS is actually loaded - sticker says XP Pro, but the boot menu offered XP Home edition... he didn't have the original disks supplied (it's a teenager's bedroom, what did I expect!) but I have both Pro and Home edition installsets at home.

Tried booting from CD and using Recovery Console...
DISKPART reports the following;
-: Partition1<EISA Utilities> 4997 MB
d: Partition3 [NTFS] 35409 MB
c: Partition2 <ACERDATA> [FAT32} 35911 MB

The cdrom is reported as E:

DIR only works on the root of each partition and I can't CD into any of the directories on the hard disk, although I can crawl around the directory tree on the CD to my heart's content.
Tried expanding the hal.dl_ from the installset using "expand e:\i386\hal.dl_ d:\windows\system32\hal.dll" - can't write to the disk, it says "Access is denied".
Then I tried rebuilding boot.ini using BOOTCFG - this found a single installation of XP, which seems correct, so I added a new pointer to it - now if I try to load that I get an error message saying
"Windows could not start because the following file is missing or corrupt:
Minint\SYSTEM32\CONFIG\SYSTEM"
- if I try to load the original one I get the old hal.dll message still.
I have been round this loop a few times now, to the OS Options menu now shows 5 different variations on the theme, none of which work. The timeout in boot.ini is set to 1 which isn't too helpful, as I have to F8 to get to the boot menu and then select the OS loader screen.

Boot.ini looks like this now;
[boot loader]
timeout=1
default=multi(0)disk(0)rdisk(0)partition(1)\Minit
[Operating Systems]
multi(0)disk(0)rdisk(0)partition(1)\Minit="MS Windows XP Home Edition" /Fastdetect
multi(0)disk(0)rdisk(0)partition(1)\Minit="MSWindows XP Home Edition"
multi(0)disk(0)rdisk(0)partition(1)\Minit="MS Windows XP Home Edition"
multi(0)disk(0)rdisk(0)partition(1)\Minit="Windows XP Home Edition"
multi(0)disk(0)rdisk(0)partition(3)\WINDOWS="Microsoft Windows XP Home Edition" /fastdetect /NoExecute=OptIn

As can be seen, there are four that I have created all pointing at partition 1 and the original pointing at partition 3. As far as I can see partition 1 is a 5GB hidden recovery partition not generally available to the OS so it's not surprising that isn't working.

I tried to remove all the duff entries and set the timeout by editing the file - the recovery console has no editors, not even ed or edlin... that's cruel.

I am open to suggestions as to what to do next.
- I tried recovering the file from the installsets but can't write to the disk
- I tried rebuilding the boot.ini and it just gets comedy entries pointing to an OS installation that doesn't exist.

My hair went grey some time ago but it's being pulled out in handfuls after an afternoon of this...
Please help rescue my reputation as a cool Auntie who is worth being nice to!
  • 0

Advertisements


#2
happyrock

happyrock

    Tech Moderator

  • Retired Staff
  • 9,285 posts
that 5GB hidden recovery partition, if run, will put the computer back to like the day you bought it...of course all the data will be gone...
or you can go the repair route...go here for the how to guide...
  • 0

#3
MrsHill

MrsHill

    New Member

  • Topic Starter
  • Member
  • Pip
  • 2 posts
Thanks for the quick response!
I don't really want to go for the return-to-delivery-config option if I can help it - an 18-year-old separated from his mp3 collection might be a scary thing to behold. Also he couldn't find the original disks which are usually required for that route as well.

I am almost fed up enough to go down the Windows Repair route... although I have spent some time cleaning up the father-in-law's machine when one of his mates helpfully ran that and it left a fearful mess.

My real concern with taking that option at the moment is the lack of clarity over what the OS actually is... the OS choice menu reported is as Hme Edn but the sticker is Pro... I have a key on the sticker and I can't really imagine that someone has installed Home over Pro - but are there any simple ways to find out what's actually on the disk, without resorting to a screwdriver? I may be forced to run the repair from the XP Pro disk and hope, but I would like to be confident rather than just hopeful, if you see what I mean!
  • 0

#4
The Skeptic

The Skeptic

    Trusted Tech

  • Technician
  • 4,075 posts
1: The data can be backed up.]

2: Regarding repair: You can start with the Home Edition disk. If it's not the right one, you will be notified and the process will not start. Then try XP Pro.

3: If your CDs are not identical to the installed version then It's very possible that Repair will not be an option, regardless of available CDs.

4: You can try to restore the system to an earlier date using Recovery Console. Follow this:

System Restore from the Recovery Console. {adapted from Geeks to Go. Original source unknown to me}. Xp installation CD required. Boot with the CD and when given the option choose to repair the computer by pressing "R", opening the Recovery Console. Type 1 when asked for OS installation (assuming there is only one OS installed). Type the administrator password when asked to do so and press Enter. Press Enter if there is no password.

* At the prompt Type: CD \
* Press Enter
* Type: cd system~1\_resto~1
* Press Enter
* Type: dir
* Press Enter

After you press enter you will see a list of folders (like rp1, rp2) If the list of restore points has more than one page then press the Enter key untill you reach the end of the list

* Type: cd rp {number of the second to last folder in the list). Example: cd rp9, if rp9 is the second to the last restore point where the last restore point no. is 10
* Press Enter
* Type: cd snapshot
* Press Enter
* Type: copy _registry_machine_system c:\windows\system32\config\system
* Press Enter
* Type: copy _registry_machine_software c:\windows\system32\config\software
* Press Enter
* Type: Exit
* Press Enter

Your PC will reboot.

If you get an access denied error when doing the above, then do the following at the recovery console:

* Type: CD \
* Press Enter
* Type: cd windows\system32\config
* Press Enter
* Type: ren system system.bak
* Press Enter
* Type: Exit
* Press Enter

Your PC should reboot

If you still cannot get access in anyway to your installation in the recovery console then your SAM database files are corrupt. There is no way you can restore these with the recovery console. You may need to do a fresh install.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP