Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

My network changes from what it should be, 'assigned by DHCP'


  • Please log in to reply

#1
Dani723

Dani723

    Member

  • Member
  • PipPip
  • 18 posts
Thanks for taking the time.

My home network consists of two pcs connected via a cable modem running into a linksys WRT54GS router, which uses DHCP protocol, and the wired setting. Operating system XP.

As the title says, sometimes, seemingly randomly, the network changes from 'assigned by DHCP' to 'automatic private address'. The change is noted on both pcs. Here are the key details.

I've left some of the information out from the 'network connection details' window below, listing what I thought was relevant. In 'network connections', the connection on the downstairs pc (the one with the modem) is listed as this when it works:

Address type: Assigned by DHCP
IP address: 192.168.xx.xx
Subnet mask: 255.255.255.0
Default gateway: 192.168.1.1
DHCP Server: 192.168.1.1
DNS Server: (two listed)

It's listed as this when it suddenly changes and cuts out the connection:

Address type: Automatic private address
IP address: 169.254.xx.xx
Subnet mask: 255.255.0.0
DNS server: (nothing listed)

I don't know what else to try, I've changed the router firmware to an older version and back again, reset the modem and router, checked all the ethernet connections were clicked in place, changed the ethernet cables port positions, hit the repair button on the local area connection status window, uninstalled the network adaptor and let windows recognise it again, and released and refreshed the ip address in the 192.168.1.1 router configuration page. No joy. Perhaps there are other option on this page I should try changing?

This has been randomly changing every few days for a little while now, and usually changes back after perhaps a few hours.

Any ideas? Thanks then.

Edited by Dani723, 21 August 2009 - 08:37 AM.

  • 0

Advertisements


#2
datarunner

datarunner

    Member

  • Member
  • PipPipPip
  • 440 posts
Hi There

Make sure your router and modem are on BEFORE you power up your clients. As when the clients boot, they look for a DHCP server via DORA (Discover, Offer, Request, Acknowledge).

Also check your DHCP lease times.

If they cannot find or be provied with DHCP info then they will revert Automatic Private IP Addressing (APIPA).

A way round this is to TURN OF APIPA and set the alternative connections to static IP's for your subnet.

Hope that helps.

Regards

Edited by datarunner, 21 August 2009 - 08:58 AM.

  • 0

#3
Dani723

Dani723

    Member

  • Topic Starter
  • Member
  • PipPip
  • 18 posts
The modem and router are always on first.

The lease times were 0 (1 day). I've set the lease time to 9999 days, as the problem occurs when the new IP's are given out. Is this wise?

How do you turn off APIPA?
  • 0

#4
datarunner

datarunner

    Member

  • Member
  • PipPipPip
  • 440 posts
Hi There

MS article:

http://support.micro....aspx/kb/220874

Requires registry editing so be careful to follow instructions EXACTLY.

Maybe do a registry backup with ERUNT

BEFORE commencing

Regards
  • 0

#5
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP

The lease times were 0 (1 day). I've set the lease time to 9999 days, as the problem occurs when the new IP's are given out. Is this wise?

since this is a local network with only 2 computers on it....setting a super massive lease time isn't an issue...however...since the root of the problem was never found (i.e. why they're going to automatic for no reason)....the problem will possibly come back...or manifest itself in other connectivity issues...i'd be inclined to wonder if the DHCP server in the router is messing up (it's all software so it's not like a hardware failure) due to some corruption or something or another...or if there is an intermittent hardware problem that's making the machines not able to get an address at the exact moment that they're asking for one (though...this would only occur during boot...if the system is ON and connected....if it doesn't get an ACK reply from the DHCP server...it just keeps it's address until told otherwise)

unfortunately...without having other hardware around this is pretty hard to test...and most people don't have multiple routers sitting in a closet...
  • 0

#6
bearqst

bearqst

    Member

  • Member
  • Pip
  • 3 posts
Why not connect both PC's directly to the cable modem and check the IP assignments. This would give some indication as to whether the APIPA is the cause and if he needs to disable it.

And check your cables, maybe replace them to see if they are causing you to lose your connect to the router.

If all appears good at this point, look into the firmware on the Linksys and consider updating it (if needed).
  • 0

#7
Dani723

Dani723

    Member

  • Topic Starter
  • Member
  • PipPip
  • 18 posts
OK. I've changed the registry, creating a DWORD 'IPConfigurationEnabled' with a value of 0x0 in the network adaptor's GUID key. When omitted, the computer automatically enables APIPA, when this is created with a value of 0x0, it is disabled. I think that makes sense...

So thanks very much for the tip. I've changed the lease time back to 0, one day, I guess it doesn't matter in any case.

We've considered buying a new router if this continues now, a backup one might come in handy as well.

We've tried firmware changes, but the connection hasn't failed us for about a week now. How can I connect two pcs with one modem?

Edited by Dani723, 29 August 2009 - 05:25 PM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP