Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

connected network but very slow 3g


  • Please log in to reply

#1
kredik

kredik

    Member

  • Member
  • PipPip
  • 59 posts
hi.
So I have a new huawei e169 modem for my toshiba satelite laptop(xp) that worked great the first month on 3g connection ,hoewever,after reaching max. of 5gb and being throttled down,Ive had horrible download speeds but have no problem when switching to 2g(gprs) connection. I have been in contact with the provider and they say Im back on 3g network and did have good speed a few times but I can barely load a page now for over 3 weeks. I did alot of tweaking due to the long wait at customer service so maybe I did something wrong. I have avast security and long ago wasted Norton successfully. Thanks for any advice!
  • 0

Advertisements







Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP