Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

ZoneAlarm update didnít work

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 2 posts
Operating System = Windows 98
AntiVirus = AVG (recently updated)
Antispyware = SpywareGuard
Firewall = Well Ė nothing now . . .

I have been using ZoneAlarm (Free Version) for several years and operating Windows 98. Upgrades have always gone well. I did the last upgrade to in Feb '05.

Just spent the last three days trying to get the upgrade to work and I get two error messages:

First message:
Could not load the DLL library C:\WINDOWS\SYSTEM\kernel32.dll. An attempt was made to load a program with an incorrect format.

When I press OK, I get the second message:
Could not load the DLL library C:\WINDOWS\TEMP\vsutil.dll. One of the library files needed to run this application cannot be found.

Then the installation stops.

I have looked over what I can find on the internet about this problem and tried several things. To summarise what I have tried:

1. I tried re-downloading the file several times. None of these worked.

2. I tried to sort out any potential problem with certificates using the regsvr32 /u command in the command mode to uninstall them, rebooting, reinstalling them and rebooting. That didn't work.

3. I went to the Verisign site and tried reloading certificates plus went to WindowsUpdate and downloaded a program to repair the root certificates. ZoneAlarm would still not install.

4. Out of curiosity, I tried to reload the old version of from the old installer file that I had saved (without first uninstalling No luck.

5. I then tried to uninstall using the uninstall ZoneAlarm button and strangely got the same two messages as above. Thus I couldnít even uninstall the existing program like many people suggest as the best way to upgrade.

6. I tried to do a clean uninstall by adding "/clean" (with a space but no quotes) to the target line for Uniinstall ZoneAlarm in Properties page and got the same two messages.

7. Then I tried to uninstall using the Windows uninstall program in Add/Remove Progams. This also produced the same two messages as above.

8. Finally I tried to manually uninstall as described in a thread about vsinit.dll problems. I was able to clear all the files from the computer but I couldn't find a registry entry for the folder "VSData95" in HKEY_LOCAL_MACHINE\SYSTEM\CurrentContolSet\Services\VxD. However I removed any entry that contained any reference to ďZone Labs.Ē

9. Iíve done a scan with CWShredder, Spybot S&D and Ad-aware SE (all updated to the most current definitions) and found nothing wrong. Then I did an online antivirus scan at the Computer Associates eTrust Web Scan site plus a scan using my own AVG antivirus software and also found nothing amiss.

ZoneAlarm seems to be gone off the computer now and it has been rebooted several times successfully. However I am still unable to load either the or versions. The same error messages come up.

If anyone has ideas, I would love to hear them.
  • 0




    Global Moderator

  • Global Moderator
  • 6,588 posts
make sure that that zone alarm is completely uninstalled.

run regedit and removed

c:\program filees\zone alarm
c:\windows\internet logs
Windows NT/2000: VSDATANT.SYS
Internet Monitor: VSMON.EXE
Basic Logging Client: MINILOG.EXE
Windows\System\Zone Labs OR WINNT\System32\Zone Labs

  • 0



    New Member

  • Topic Starter
  • Member
  • Pip
  • 2 posts
Hi Starjax:

Sorry I didn't reply right away. The company sent me away for a week and then it took some time to get back into it.

Okay, I've done all you said. Even checked for hidden files. However, I still can't get the installer to work.

Also, I tried downloading some earlier versions. zlsSetup_45_594_000.exe and zlsSetup_51_033_000.exe. Neither one of them would install either.

Any other thoughts?
  • 0

Retired Tech

Retired Tech

    Retired Staff

  • Retired Staff
  • 20,563 posts
You can get those files here to see if it lets you install


  • 0



    New Member

  • Member
  • Pip
  • 1 posts
I recently did an update (to windows 98 se) and found that my computer would hang. Figuring that it was an update problem, uninstalled updates until it booted up properly again...

When it booted up properly again, I noticed that Zonealarm loaded when previously it hadn't. Seeing your issue helped me make a connection...

Windows update KB891711 apparently modifies Kernel32.DLL causing problems to Zonealarm. This is just an observation I have made, I can not back it up with technical data/detail, just that my Win98 box booted after uninstalling the update.

Hope this helps you somehow or sparks a thought in someone that will give a resolution...

  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP