Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Onboard Network Adapter Missing


  • Please log in to reply

#1
EricJB

EricJB

    Member

  • Member
  • PipPip
  • 19 posts
Hey guys. Weird issue here. I got a blue screen earlier which was attributed to cdd.dll. I restarted the PC and it crashed again after about 10 minutes.

Last time I had this problem, I reseated my RAM sticks and that fixed the problem. It fixed the problem this time, too, as it doesn't crash anymore.

Now, however, my network adapter has gone missing... completely. Both from network connections and the device manager. Windows 7 is telling me I don't have any network hardware installed. I also have no connection on my Windows XP partition.

The network adapter is built into my Intel D915GAG motherboard. And the yellow LEDs are still lit up on the adapter itself, so I assume it's still working.

I even checked in BIOS to make sure the adapter was enabled, and it was.

Any ideas? It just sort of happened out of the blue here.

Thanks in advance.

EDIT: Forgot to note: I also tried a system restore, restoring the system to a day earlier and the problem still exists.

2ND EDIT: Went out and bought a Linksys Ethernet Card and instaleld it into my last open PCI slot. Popped the Installation CD in and I couldn't get it to install the drivers on Windows 7. So I popped over to my Windows XP partition and installed the drivers there no problem. Rebooted the PC and got internet on the XP Partition.

Back to Windows 7, still no internet. In device manager, the the new card shows up as Other Devices > Ethernet Controller and it has a yellow exclamation mark next to it. It still needs drivers.

But here's the strange part. My original onboard network adapter suddenly is showing up in device manager again and it's working.

Any idea what's happened here? Really weird stuff.

Thanks a lot!

Edited by EricJB, 16 September 2009 - 02:49 PM.

  • 0

Advertisements







Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP