Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

SATA problems on my ASUS P5KPL-E board

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
I use an ASUS P5KPL-E mobo with 3SATA drives
Western Digital 250G
Seagate 500G
Asus DVD+/- writer 20X

Lately Ive been encountering problems with the SATA ports, I recently replaced my SATA cables due to a the same problem last August where my SATA1 port malfunctioned and wouldnt identify/read the HDD (where my OS was in), the other ports 2-4 worked fine (I tried transferring my drives to them and they worked).
However, the cable replacement didnt work until I decided to do a CMOS reset and SATA1 came back to life.

unfortunately just this morning before I went to class however, the same problem occurs except that the affected ports are SATA2-3, I have yet to try SATA4 port or do another CMOS reset after my classes today.

Any insight on what could be the problem in my Mobo?
  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP