Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

New Built Computer, Running slow

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
Hey all,

Recently I just built my First computer, and I use it for gaming, and really only gaming.


2.66 GHZ Quad Core Processor.
Windows XP 32 Bit (Too poor, can't afford 64 bit. Yet)
4 Gig DDR3 Ram
Gigabyte GTX 260
500gig Hard Drive.

I've been using it for about a week, just playing games like Crysis, CoD4, Resident Evil 5, Oblivion, etc. All been running fine and smoothly. Today on startup, I noticed it took ages to load up, and when I clicked on my user name Profile, it took a long time to load, and even then, the desktop loaded all distorted, and they had to still load.

I use CCleaner Ever night, Use BitDefender for viruses, the power save mode is set to High performance (Sorry atmosphere) and monitor my computers heat regularly.

Is there a explanation for this random drop in performance?

Thank you in advance.
  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP