Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Weird boot-up + unable to drag objects.

  • Please log in to reply

Ryan S

Ryan S


  • Member
  • PipPip
  • 17 posts
Just got back from school and went to turn on my computer, an "American Megatrends" screen appeared and seemed to be doing checks which is the first time this has happened, also when starting up before it gets to the login page the tower beeps twice.

It logs in OK but I'm unable to drag anything, from tabs in the browser to files. I've tried System Restore and went back to Friday but to no avail. Not sure if these two are related.

Many thanks,


EDIT: Nevermind, I found an old keyboard (because my previous keyboard was starting to act up) and plugged it all in and when I re-started my computer it worked!! :) I can now drag and drop and it doesn't have some weird start-up. Thanks anyways!

Edited by Ryan S, 22 September 2009 - 08:05 AM.

  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP