Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

laptop screen keeps going blank

  • Please log in to reply




  • Member
  • PipPip
  • 94 posts
Not actually sure if this is a hardware problem or a settings problem.

This is my Dad's laptop so I dont have *all* the information, but I have a decent summary of the problem. Laptop is Dell Inspiron 1520.

He was working on it and suddenly the screen went blank. Tried moving the mouse etc but it wouldn't come back. Shut down (by power button not start-shutdown), started again. Waited a few minutes, same problem happened. Went through this cycle a number of times. At one of the times, perhaps the third, there was an error message. Dont remember exactly what it said, something along the lines of settings have been corrupted, but it included the words 'corrupted', 'restore', and i think 'backup'.

When I took a look at it the first thing I noticed was the screen was much darker, kinda like when a laptop is not plugged in to the power. This one was plugged in though, and the taskbar showed it was getting powered directly from the power source. When I opened a browser the whole screen seemed to be having display problems, seemed to keep getting darker and lighter. Finally monitor shut off. When it went off I could very very slighty make out some images on the screen, and music kept playing, thus indicating just the screen went off but the computer was still working fine.

In case its relevant I checked the display settings:

Two display options in the dropdown.

The selected one says:

1. Plug and Play Monitor on Mobile Intel® 965 Express Chipset Family

The second one says
2. (Default Monitor) on Mobile Intel® 965 Express Chipset Family

Screen resolution is set to 640 x 480. Color quality is low, 8 bit.

Any ideas how to fix this?

  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP