Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Vista + D-Link DIR-615 = [bleep]

  • Please log in to reply




  • Member
  • PipPip
  • 41 posts
So I got my new computer, Acer Aspire, quad core, 4gbs, but I don't think that matters much. What matters in this case is that I just got a new PC and It simply cannot connect to my Router. I've tried everything, but Vista is just a cluster****. I have a D-link DIR 615 on a WEP connection because WEP seems to be faster for online gaming (PS3). Its using a PPPoE internet connection, I get basically 85-100% on my PS3 and my computer is right beside it. I usually get 4 to 5 bars for the network connection on my Vista PC. So I know its not connection. My router is relatively new by maybe 8 weeks. It connects fine to everything else in my house so it must be Vista. Please help, anyone.
  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP