Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Access Denied on LAN


  • Please log in to reply

#1
musicarvind

musicarvind

    New Member

  • Member
  • Pip
  • 3 posts
I got four computers on the network in the office. Small office. Every computer can view other computers on the network except that 3 of the computers cannot browse folders on the computer that is the gateway to the internet. All computers can browse the net. I have shared some of the folders on this computer and other computers (clients) can see the folders, but when they click on the folders, it says Access Denied, contact administrator of folder permissions blah blah blah. I tried all kinds of things. Folders are shared but still why cant other browse these folders??? Please help cause everything is set on the network except for other computers not being able to browse my folders.
  • 0

Advertisements


#2
volcomssj48

volcomssj48

    Member

  • Member
  • PipPip
  • 25 posts
I had this problem once...

I used good ol' guessing. :tazz:
anyway what I did worked, so maybe you can give it a try. It doesnt harm your computers in any way.


anyway, I just disabled all the firewalls on all the computers, and went to the Properties window of the folders. (right click on the folder > properties) and checked read-only. Then I did that again but this time, unchecked read only on all the folders.

Then, I put them up for sharing.

Then, I restart the computers, and whala, it works.

Yeah, it sounds dumb but it works for me.
  • 0

#3
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
Hello musicarvind,
If you are positive that you have already 'Shared' the folder on the network, then try some of the following:
Enter Administrative Tools (If you're using Windows XP, goto Start, Settings, Control Panel, Performance and Maintenance, and then Administrative Tools). Expand 'Local Policies', and then double click 'Security Options'. In the list provided, you should see 'Accounts: Guest Account Status' -- is it Enabled? If not, double click on it and then select the Enabled option.

Now, go to 'Local Policies', and then 'User Rights Assignment'; double click on 'Access this computer from the network' -- in the list of users, make sure that 'Everyone' is there (if not, add it). Go to 'Deny access to this computer from the network', open it, and if the account 'Guest' is in the list, remove it.

On one of the slave computers, go to start > run > cmd > net view [Hosts IP] -- ie: net view \\192.168.10.2
If you recieve the message "There are no entries in the list", then that means you have not set up sharing properly.
To find out what folders you're sharing, go into Command Prompt, and type: net share
Are all the computers using the same Operating System? If not, what os are they using?
  • 0

#4
musicarvind

musicarvind

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts
Hi volcom and Dan G. Tried both of your recomendations but still having the same problem. Dan, On the Local Policies and User Rights Assignment, it was already what you recommend. On a slave computer i did a cmd and net view of the computer IP i am trying to access. It says "Access is Denied". On my command prompt, I did a net share and it showed all the folders i am sharing.

This is really weird. Any more suggestions???? It was ok before. Its driving me crazy, cant crack this nut. Any further help appreciated.

arvind/..
  • 0

#5
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
Just for testing purposes, (on the host computer) go back into 'Local Policies' and then 'Security Options', and then select 'Network Access: Let Everyone permissions apply to anonymous users'. Enable it. Can the three slave computers now modify folders?

Also, when you shared folders, did you also tick 'Allow network users to change my files'?
And.. Does the user account on the server machine have the exact same name and password as you use to logon to the client machine? They all need to be the same.

I trust you have all firewalls disabled?
  • 0

#6
-=jonnyrotten=-

-=jonnyrotten=-

    Member 2k

  • Retired Staff
  • 2,678 posts
Also just curious here, but what OS are you running XP Professional or Home? Service pack 1 or 2?

-=jonnyrotten=- :tazz:
  • 0

#7
musicarvind

musicarvind

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts

Just for testing purposes, (on the host computer) go back into 'Local Policies' and then 'Security Options', and then select 'Network Access: Let Everyone permissions apply to anonymous users'. Enable it. Can the three slave computers now modify folders?

Also, when you shared folders, did you also tick 'Allow network users to change my files'?
And.. Does the user account on the server machine have the exact same name and password as you use to logon to the client machine? They all need to be the same.

I trust you have all firewalls disabled?

View Post



Hi Dan and Jonnyrotten,

Dan, "Network Access: Let Everyone permissions apply to anonymous users" was disabled. Enabled it and still not accessible. Yeah, i did tick on "Allow network users to change my files". Still nothing.

There are no logons as far as when the computer starts up. Firewall only enabled for Internet Broadband direct connection. As far as LAN settings are concerned, no firewalls. Actually my computer is not really a server. It just serves as an Internet Gateway. Part of an infrastructure connected to others with LAN switch and a Wi-Fi Access Point. I still don't get it. Thanks for all your help though. Still not working.

jonnyrotten, am using XP Professional SP1.

arvind..
  • 0

#8
stoyles

stoyles

    New Member

  • Member
  • Pip
  • 1 posts
1. Click Start, and then click My Computer 2. On the Tools menu, click Folder Options, and then click the View tab. 3, In the Advanced Settings section, clear the Use simple file sharing (Recommended) check box 4. Click OK
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP