Jump to content

Welcome to Geeks to Go - Register now for FREE
Geeks To Go is a helpful hub, where thousands of friendly volunteers serve up answers and support. Get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute.
Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message and all ads will be removed once you have signed in.
Create an Account Login to Account

Windows update problem-Files required are no longer registered


  • Please log in to reply

#1
zoots

zoots

    Member

  • Member
  • PipPip
  • 11 posts
Today I went to do a Windows update and got the following message:
"Files required to use Microsoft Update are no longer registered or installed on your computer"
It gave me two options:
1. Register or reinstall the files for me now (Recommended)
2. Let me read about more steps that might be required to solve the problem
When I use the 1st option I get the msg: 403 - Forbidden: Access is denied.
When I use the 2nd option I'm sent to a Microsoft site that provides for an
automatic download of the latest update program. That link downloaded the
Microsoft Update program for me and immediately gave me the same message:
"Files required to use Microsoft Update are no longer registered or installed on your computer"
I get the same problem on my wife's user ID.
I went to Add or Remove- tried to add "Windows Update" from Microsoft programs and got
the same messages again.
Do you know of any way to fix this dilemma?
I ran a MalwareBytes log and put it below, if it's of any use.
A recent virus scan showed nothing.
Thanks for any help.
++++++++++++++++++++++++++++
Malwarebytes' Anti-Malware 1.41
Database version: 2947
Windows 5.1.2600 Service Pack 3

10/12/2009 11:45:41 AM
mbam-log-2009-10-12 (11-45-41).txt

Scan type: Quick Scan
Objects scanned: 147963
Time elapsed: 9 minute(s), 15 second(s)

Memory Processes Infected: 0
Memory Modules Infected: 0
Registry Keys Infected: 0
Registry Values Infected: 0
Registry Data Items Infected: 0
Folders Infected: 0
Files Infected: 0

Memory Processes Infected:
(No malicious items detected)

Memory Modules Infected:
(No malicious items detected)

Registry Keys Infected:
(No malicious items detected)

Registry Values Infected:
(No malicious items detected)

Registry Data Items Infected:
(No malicious items detected)

Folders Infected:
(No malicious items detected)

Files Infected:
(No malicious items detected)

Edited by zoots, 13 October 2009 - 06:03 AM.

  • 0

Advertisement


#2
zoots

zoots

    Member

  • Member
  • PipPip
  • 11 posts
After some research on my previously stated problem I performed the following:
------------
Method 1: Register the Msxml3.dll file
If you experience this problem on a computer that is running Windows XP or Windows Server 2003, register the Msxml3.dll file.
To register the Msxml3.dll file, click Start, click Run, type regsvr32 msxml3.dll, and then click OK two times.
-------------
The above solved the problem for me but when I tried the same procedure
on my wife's user account (w/admin rights) I keep getting the error:
dllregisterserver in msxml3.dll failed
Return code was: 0x80004005.
I think it might have to do with permissions but I don't know.
Thanks for any help on this continuing problem.
  • 0



Similar Topics: Windows update problem-Files required are no longer registered     x


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

featured