Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

FarCry2 Serious lag on DirectX10


  • Please log in to reply

#1
BlackHalo

BlackHalo

    Member

  • Member
  • PipPipPip
  • 266 posts
Hi,

I had FarCry2 installed on my currrent machine a while back and could run it on Ultra settings with DirectX10 selected without any issues and without serious lag or performance issues (apart from the odd glitch or framerate drop here and there, but nothing to write home about).

However, I've had to format my machine a week or two ago and after reinstalling FarCry2, I can't seem to run it on DX10 without serious lag. It honestly looks like I'm running it on a 486! And this includes stuff like the intro sequences and menu. Everything just slows down to a crawl. On DX9 it works perfectly, but the moment I go over to DX10, it almost stops...

I've also had some run-ins with Mirror's Edge. For some reason during play it crashes sometimes (especially when switching to reaction time) and sometimes the sound suddenly stops playing. I played it on mute for half an hour at one point...

I've tried updating DX and have tried updating other components, but it just keeps doing what it's doing...?

My system specs:

Windows: Microsoft Windows VISTA 6.0.6001 Service Pack 1
Internet Explorer: 7.0.6001.18000
Memory (RAM): 4092 MB
CPU Info: Intel® Core™2 Quad CPU Q9400 @ 2.66GHz
CPU Speed: 2662.1 MHz
Sound card: Speakers / HP (IDT High Definit
Display Adapters: NVIDIA GeForce 9800 GT | NVIDIA GeForce 9800 GT | RDPDD Chained DD | RDP Encoder Mirror Driver
Monitors: 1
Screen Resolution: 1600 X 900 - 32 bit
Network: Network Present
Network Adapters: Intel® 82567LF-2 Gigabit Network Connection
CD / DVD Drives: D: ATAPI iHAS322 8 | F: MagicISOVirtual DVD-ROM | G: MagicISOVirtual DVD-ROM
COM Ports: NOT Present
LPT Ports: NOT Present
Mouse: 8 Button Wheel Mouse Present
Hard Disks: C: 232.9GB | E: 465.6GB
Hard Disks - Free: C: 137.3GB | E: 96.3GB
USB Controllers: 8 host controllers.
Firewire (1394): Not Detected
PCMCIA (Laptops): Not Installed
Manufacturer: Intel Corp.
Product Make:
AC Power Status: OnLine
BIOS Info:
Time Zone: South Africa Standard Time
Battery: No Battery
Motherboard: Intel Corporation DP45SG
Modem: Not detected


Thanks.
  • 0

Advertisements







Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP