Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Unknown Icons


  • Please log in to reply

#1
Nilla

Nilla

    Member

  • Member
  • PipPip
  • 92 posts
Hello,

I was working with Microsoft Blend. I uninstalled it and the icons for the HTML and PHP files changed. I haven't lost any functionality with the files but its just annoying. The HTML files used to display a FF icon and the PHP files would display Dreamweaver icon. Now HTML in an unknown icon and PHP display the notepad icon. Its been like this for a few months and now it has bothered me too much. How can I change the default icons? I run windows xp home.

I attached a screen shot as an example.

Thanks!

Attached Thumbnails

  • example.JPG

  • 0

Advertisements


#2
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
Hello Nilla...

The files have been stripped of their associations with a program.

Open Control Panel and double click on the Folder Options icon. Under the "File Types" tab, scroll down the list to HTML and click on it. Click on the "Change" button.

In the window that opens, locate and select Firefox from the list of recommended programs...click Ok. You'll want to do this for HTM files, too, if they aren't still associated with Firefox.

Do the PHP files the same way only choosing Dreamweaver as the associated program.

wannabe1
  • 0

#3
Nilla

Nilla

    Member

  • Topic Starter
  • Member
  • PipPip
  • 92 posts
Thanks wannabe1! Does a restart need to be done for the changes to take effect? I followed your steps and the icons didn't update.
  • 0

#4
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
Sometimes Windows does require a restart to set the change in the registry. Restart...if things aren't back the way they should be, we'll look a bit deeper.
  • 0

#5
Nilla

Nilla

    Member

  • Topic Starter
  • Member
  • PipPip
  • 92 posts
I did a restart and the php file icon changed but the html/htm icon didn't. I checked the folder options and both html and htm are set to FF icon.

I tried to create a new file type. As a test I made the File Extension "HTML" and the Associated File Type "Firefox Document" as apposed to "HTML File". If you look at the image I attached in the first post, it says FF Doc and not HTML file. However, I clicked OK and I can't find the new extension in the list. I don't think it was created because there is already an HTML extension in my list.

Looking further into my list of file extensions HTM and HTML both have a Restore option. The message says "You have customized files with extension 'HTML'. To restore these files to their default type (Firefox Document), click Restore."

Similarly, the PHP extension also has the restore button. But the message for PHP files is incorrect. It displayed the PKO extension message. It says "Files with extension 'PKO' are of type 'Public Key Security Object'. To change settings that affect all 'Public Key Security Object' files, click Advanced." There is not an Advanced button, but there is a Restore button.

Do I click the Restore buttons?

I attached another screen shot because I don't know if I described that very well. No other extensions have the restore button.

Thanks!

Attached Thumbnails

  • example.PNG

  • 0

#6
Nilla

Nilla

    Member

  • Topic Starter
  • Member
  • PipPip
  • 92 posts
Any suggestions on this?

Thanks
  • 0

#7
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
Sorry for the delay in getting back to you. I either missed or didn't get a notification of your reply.

Did you try clicking on the "Restore" button?
  • 0

#8
Nilla

Nilla

    Member

  • Topic Starter
  • Member
  • PipPip
  • 92 posts
No problem. No I haven't clicked it. I was waiting on your word.
  • 0

#9
Nilla

Nilla

    Member

  • Topic Starter
  • Member
  • PipPip
  • 92 posts
Alright, well I guess I'll try the reset button. If that doesn't work I'll look for help elsewhere. Thanks anyway.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP