Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Cannot Escape the Blue Screen of Death


  • Please log in to reply

#1
tennisgiant21

tennisgiant21

    Member

  • Member
  • PipPip
  • 30 posts
Hi guys,

A few days ago I ran into the Blue Screen of Death, and have not been able to boot up to Windows since.

It is an old Dell Dimension 4600, purchased back in '03, running XP Professional and Service Pack 3.

The blue screen does not reference a specific error, but under technical details. it shows "0x0000007E"

I tried booting up via safe mode, still get the blue screen. Tried the "boot up using the last safe or configuration" option, same deal.

It starts displaying dozens of driver names, and the last line before the blue screen shows up is "agp440."

I have removed ram, video card, sound card, and tv tuner card separately, to see if it was a hardware issue with any of those, no luck.

I was planning on getting a new computer anyways, no not a huge loss, but I would like to be able to boot up, at least so I can save my hard drive contents.

Any suggestions or advice would be much appreciated.

Thanks,
-Brian
  • 0

Advertisements


#2
rshaffer61

rshaffer61

    Moderator

  • Moderator
  • 34,114 posts
Hello tennisgiant21.... Welcome to GeeksToGo, :) :) :)

I'm sorry to hear about your issue. We will try to help you resolve this as soon as possible.
Please understand we are all volunteers and we are not here all the time. Sometimes it may be a extended amount of time to get back to you. If it has been more then 3 days please shoot me a PM and I will try to get back to you quickly then.

First issue is as long as the drive is not defective there is a good chance you can retrieve the data.
Second of all did you upgrade any drivers or software before this issue started?
Any new hardware added?
Next please run the next steps in order and reply back with results after each test.

Run hard drive diagnostics: http://www.tacktech....ay.cfm?ttid=287
Make sure, you select tool, which is appropriate for the brand of your hard drive.
Depending on the program, it'll create bootable floppy, or bootable CD.
If downloaded file is of .iso type, use ImgBurn: http://www.imgburn.com/ to burn .iso file to a CD (select "Write image file to disc" option), and make the CD bootable.

NOTE. If your hard drive is made by Toshiba, unfortunately, you're out of luck, because Toshiba doesn't provide any diagnostic tool.

Thanks to Broni for the instructions


If you have more than one RAM module installed, try starting computer with one RAM stick at a time.

NOTE Keep in mind, the manual check listed above is always superior to the software check, listed below. DO NOT proceed with memtest, if you can go with option A

B. If you have only one RAM stick installed...
...run memtest...

1. Download - Pre-Compiled Bootable ISO (.zip)
2. Unzip downloaded memtest86+-2.11.iso.zip file.
3. Inside, you'll find memtest86+-2.11.iso file.
4. Download, and install ImgBurn: http://www.imgburn.com/
5. Insert blank CD into your CD drive.
6. Open ImgBurn, and click on Write image file to disc
7. Click on Browse for a file... icon:

Posted Image

8. Locate memtest86+-2.11.iso file, and click Open button.
9. Click on ImgBurn green arrow to start burning bootable memtest86 CD:

Posted Image

10. Once the CD is created, boot from it, and memtest will automatically start to run.

The running program will look something like this depending on the size and number of ram modules installed:


Posted Image

It's recommended to run 5-6 passes. Each pass contains very same 8 tests.

This will show the progress of the test. It can take a while. Be patient, or leave it running overnight.

Posted Image

The following image is the test results area:

Posted Image

The most important item here is the “errors” line. If you see ANY errors, even one, most likely, you have bad RAM.
  • 0

#3
tennisgiant21

tennisgiant21

    Member

  • Topic Starter
  • Member
  • PipPip
  • 30 posts
Hi rshaffer61,

Thanks for your help so far! I will try and answer all of your questions in the order in which they were posted:

1) No, I had not recently upgraded any drivers, hardware or software before the problem started. It all began when I was browsing the internet, and suddenly I got a pop-up from Zone Alarm. It read "the program named 'run' wants to connect to the internet. Allow/Deny?" I suddenly got a sick feeling, thinking it was malware, and hit "deny." To my surprise, my browser automatically closed, and got the BSOD a minute later.

2) I am having some trouble creating a boot CD to diagnose my hard drives. My current backup computer is an iMac (pre-Intel), which is unfortunately unable to run ImgBurn. What I ended up trying was downloading the appropriate .iso file, and then burning to a CD using Finder. I popped the CD into my sick PC, but did not boot from the CD, instead acting as if there was no CD in the drive. I then burned another CD, this time using Disk Utility, but to no avail - same problem. I went to the sick PC's BIOS setup, to change the boot sequence, to have the CD drive read before the C: hard drive, but nothing changed. I popped the CD back in the iMac, just to confirm that I really had burned the ISO to the disk, and sure enough, I did. What I had originally downloaded as one .iso file now appeared as several .bat, .sys, and .com files inside several folders.

As an alternative (not sure how strong an alternative though), I went to the sick PC, and hit F12 at startup to reach Boot Setup. I went to "IDE Drive Diagnostics," scanned both of my hard drives, and for what its worth, both drives "passed."

3) Testing RAM: I have 4 sticks of RAM installed, so I opted to take the "manual hardware" test, by isolating each stick. Unfortunately I got the same BSOD after each attempt. I also tried sticking the ram into different slots, to see if it was just a problem with part of the motherboard, but still got the BSOD.

I hope this helped - any more suggestions would be much appreciated!

Thanks,
-Brian

Edited by tennisgiant21, 27 October 2009 - 08:19 PM.

  • 0

#4
rshaffer61

rshaffer61

    Moderator

  • Moderator
  • 34,114 posts
Well let's try another way.
You will need to probably use a pc and not a mac on this but you can try it with the mac.

How To Run Chkdsk /r from Recovery Console:


How to run checkdisk from recovery console (Windows xp). (Courtesy dsenette)
  • Insert the Windows XP startup disk into the floppy disk drive, or insert the Windows XP CD-ROM into the CD-ROM drive, and then restart the computer.
    Note:Click to select any options that are required to start the computer from the CD-ROM drive if you are prompted to do so.
  • When the "Welcome to Setup" screen appears, press R to start the Recovery Console.
    Note:If you have a dual-boot or multiple-boot computer, select the installation that you want to access from the Recovery Console.
  • When you are prompted to do so, type the Administrator password. If the administrator password is blank, just press ENTER.
  • At the Recovery Console command prompt, type the following then press Enter:

    chkdsk /r

  • Allow this to run UNDISTURBED until completed (45 min or so)
  • Report any errors


If we could get into at least Safe Mode there would be some deeper scans to run.
Does you system have a onboard video card along with a agp video?
If so try hooking the monitor into the onboard and booting up.
Another thing we can try is to see if the BSOD information has changed by doing the following steps.

BSOD outside of Windows

  • Start your system and at the Second post screen tap on F8 to get to the Boot Menu
  • Use the Arrow Keys to Scroll down to the line that says "Auto Start On Error" and highlight it.
  • Click Enter to disable it
  • The system should reboot and if not then do so.
  • When the BSOD shows it will stop so that you can reply with the STOP ERROR and any parameters.

  • 0

#5
tennisgiant21

tennisgiant21

    Member

  • Topic Starter
  • Member
  • PipPip
  • 30 posts
I think we're making some progress!

Just for kicks, I turned the PC on again, and chose the one option I hadn't tried yet..."Safe mode with command prompt only," and the BSOD was bypassed!

I am not too familiar with DOS, but I did punch in "chkdsk." I will let you know what the results are when it's done!

-Brian
  • 0

#6
rshaffer61

rshaffer61

    Moderator

  • Moderator
  • 34,114 posts
You will need to type in
chkdsk /r

Note the space between the k and the /r
The /r is what repairs the disk if problems are found
  • 0

#7
arjirik

arjirik

    New Member

  • Member
  • Pip
  • 6 posts
I have the same issue, though I know a virus is causing it. It completely disabled my AV software (McAffee) and now when I attempt to reboot I automatically get logged off at the blue screen.

I read your May 09 post and have created a Linux puppy CD. It seems to be working ok until it detects the keyboard and mouse, at which point everything stops and the cursor just sits there and blinks.

I would really like to extract my data. I got complacent over time and didn't back up and now I have a ream of stuff I don't want to lose. Is there something else I can do with the puppy CD or would you suggest an alternative at this point?

Thank you so much for your assistance.

Allan
  • 0

#8
rshaffer61

rshaffer61

    Moderator

  • Moderator
  • 34,114 posts
arjirik I would normally have you start your own topic but your issue is a simple resolution.
Take you hd out and slave it to a known working system.
This will allow you to access the hd and backup just your data files.
Not knowing what virus you have been infected with I don't suggest you back up any
exe
html
scr
bat
com
type files as they may contain some infection.
  • 0

#9
arjirik

arjirik

    New Member

  • Member
  • Pip
  • 6 posts
Ok thanks!!! I'll try that.
  • 0

#10
tennisgiant21

tennisgiant21

    Member

  • Topic Starter
  • Member
  • PipPip
  • 30 posts
Okay, so here is a little update since I last posted...

I was feeling confident after I was successfully able to get into safe mode. I was planning on doing the chkdsk /r, but I got a message saying I had to restart before it could do this function. After the restart, I was never able to get back to safe mode.

At that point I was fed up with troubleshooting, I decided to declare my PC "clinically dead" - I have my eyes set on the new quad core iMacs coming out later this month.

Anyway, I purchased an external enclosure for my 2 old hard drives. I connected it into my backup machine (old non-Intel G5 iMac), and the drives were recognized...for the most part.

My hard drive setup on my dead PC was as follows:

Hard Drive #1 - 320 GB capacity, partitioned into a smaller C: (20GB) with my OS and main programs, and most (300GB) into Z: which has music, videos, etc

Hard Drive #2 - 120 GB - unpartitioned, labeled F:

The Mac recognizes Hard Drive #2 fine. However, it does not recognize both partitions inside Hard Drive #1, it only recognizes the C: and its 20GB capacity. When using finder inside Hard Drive #1 I see a couple of files that look suspicious, like they might be related to the 2 partitions? Their icons are grey rectangular boxes, with green font on the upper right hand corner. The file name is "Volume {52C8E4FE-B853-42c1...7838BBF3}", and the other is "Volume {52C8E4FE-B853-42c1...7838BBF3}_Backup"

Are there any measures I can take to get the mac to recognize the larger partition (assuming it didn't get fried when my old PC died?)

Thanks in advance,
-Brian
  • 0

Advertisements


#11
rshaffer61

rshaffer61

    Moderator

  • Moderator
  • 34,114 posts
Did the chkdsk /r program run at all?
The data can be recovered by using a linux live cd like Puppy linux.
You will need to put the hd back into the original system and then follow the instructions below to get the linux program and make a live cd to backup your data.


Get Puppy Linux...Get puppy-2.16-seamonkey-fulldrivers.iso download it and burn it to cd
..
if you don't have a burning program that will burn .ISO files get Burncdcc from my signature...it is a small FAST no frills iso burning program...

NOTE...do not put a blank cd in until burncdcc opens the tray for you
1. Start BurnCDCC
2. Browse to the ISO file you want to burn on cd/dvd ....in this case its memtest86.iso
3. Select the ISO file
4. click on Start

make sure in the bios the cd drive is the first boot device....

put the cd in the cd drive..boot your computer....puppy will boot and run totally in ram...if your hardware is is good working order you will know...
after you get it running and your at the desktop...you take the puppy linux cd out and then you can use the burner to copy all your data to cd/dvds
you can also use it to backup your data to a external usb harddrive..just have it hooked to the computer when you boot up with puppy...

==========================
quick guide for saving data...music..files on a system that will not boot using puppy Linux..


after you get to puppy desktop..
click on the drives icon...looks like a flash drive...top row..it will list all the drives connected to

your computer...

click on the red icon for the drive you want to mount...in this case its a flash drive ...puppy will

mount the drive..the drive icon turns green when its mounted...
minimize the drives mounter window..you will need it again in a few minutes..
drag the right edge of it sideways to shrink it to its narrowest size...about half the width of the screen...then drag the window to the right edge of the screen...

now click on the icon that looks like a filing cabinet (kind of yellow) on the main drive...it should
already be green..
you will see a list of all the folders on the main drive Usually your C: drive..shrink that window to
the narrowest you can..about half the width of the screen...drag that window to the left side of the screen...
at this point you should have 2 windows open on your desktop..the flash drive on the right side..
go back to the folders on the C: drive...click on the documents and settings folder...then your user
name or all users..find the folders that has your data..
drag and drop the folder with the data you want to make copies of to the flash drive window...

your options are to move ..copy ect...JUST COPY..if its to big you will have to open the folder and
drag and drop individual files until the flash drive is full...(I have a 120 GB external USB drive for
big data recovery jobs and a 4 GB flash drive for the smaller jobs)..after you get the files copied to
the flash drive...
Click on the drives mounter you minimized earlier
UNMOUNT THE FLASH DRIVE by clicking on the green icon..you will once in awhile get error messages when
unmouting the drive..ignore them..when the flash drive icon turns red again its safe to remove the
flash drive..trot on over (stroll if you want to look cool) to another computer and plug in the flash

drive and copy all the data files ( I drag and drop) to the other computer..
make sure the other computer can read them...

now delete the data on the flash drive...take it back to the misbehaving computer and plug it in

again..click on the drives icon again and repeat until you have all your data transferred to the working
system..
  • 0

#12
tennisgiant21

tennisgiant21

    Member

  • Topic Starter
  • Member
  • PipPip
  • 30 posts
rshaffer61, you have given me some hope! :)

I was able to boot up with Puppy Linux. Turns out I had failed to configure the boot sequence correctly. I made sure to list my CD drive as #1, but the problem was that none of the options had a checkmark, hehe.

I am browsing through my hard drive contents, and the appearance mirrors what I saw using my backup machine. The backup unpartitioned hard drive shows all of its contents, while the main, partitioned hard drive is not fully recognized. The smaller partition is showing, while the larger one is not.

The only issue I have left at this point is figuring out whether that missing partition became corrupted, and if not, getting it to show on screen. Is there a function similar to "chkdsk /r" on Linux?

Thanks,
-Brian

P.S. I am shocked at how cool Linux is. Just a 90MB boot disc brought me an OS that got me web browsing again in just a few minutes, plus being able to view Word documents, access my music and videos without installing any extra codecs or drivers...way cool.
  • 0

#13
rshaffer61

rshaffer61

    Moderator

  • Moderator
  • 34,114 posts
Actually there is not much the newer Linux's cannot do.
They have a very good history
No need for a virus protection as no problem there.
Linux has several flavors and even a brand new one named PCLinuxOS that looks alot like WIN7.
BTW they are free.
As far as the chkdsk command I did find this for you.

Linux has no need for defrag since linux filesystems handle fragmentation on
the fly.

fsck is the chkdsk equivalent.


  • 0

#14
tennisgiant21

tennisgiant21

    Member

  • Topic Starter
  • Member
  • PipPip
  • 30 posts
Hooray, the drive is now being recognized, and is accessable too!

In Linux, instead of using the "mount/unmount" utility, I went into the "Media Utility" tool, and to my surprise, the drive appeared from the get-go.

Rshaffer61, I appreciate all your help during these past couple weeks :)

Thanks,
-Brian
  • 0

#15
rshaffer61

rshaffer61

    Moderator

  • Moderator
  • 34,114 posts
So everything is now working correctly for you?
You can now backup your data with no problem?
Let me know and I will monitor for your reply.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP