Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Running a Call of Duty/uo server @home


  • Please log in to reply

#151
dadicted

dadicted

    New Member

  • Member
  • Pip
  • 4 posts
i posted it in 2 places, this one first then realised that this is the wrong place and reposted it in another place. i will delete this one if i can find out how.
  • 0

Advertisements


#152
.:007:.

.:007:.

    Member

  • Member
  • PipPip
  • 10 posts
Here are screenshots of my port forwarding and DMZ settings:
SBG940_Port_Forwarding.jpg SBG940_DMZ_Settings.jpg
Are they correct? It's still not publishing to the internet server list???

My Console:
COD MP 1.5 build win-x86 Nov 10 2004
----- FS_Startup -----
Current language: english
Current search path:
C:\PROGRA~1\CALLOF~1\main\pakb.pk3 (60 files)
C:\PROGRA~1\CALLOF~1\main\paka.pk3 (41 files)
C:\PROGRA~1\CALLOF~1\main\pak9.pk3 (149 files)
C:\PROGRA~1\CALLOF~1\main\pak8.pk3 (235 files)
C:\PROGRA~1\CALLOF~1\main\pak6.pk3 (3 files)
C:\PROGRA~1\CALLOF~1\main\pak5.pk3 (4858 files)
C:\PROGRA~1\CALLOF~1\main\pak4.pk3 (1668 files)
C:\PROGRA~1\CALLOF~1\main\pak3.pk3 (1992 files)
C:\PROGRA~1\CALLOF~1\main\pak2.pk3 (694 files)
C:\PROGRA~1\CALLOF~1\main\pak1.pk3 (2642 files)
C:\PROGRA~1\CALLOF~1\main\pak0.pk3 (12816 files)
C:\PROGRA~1\CALLOF~1/main
C:\PROGRA~1\CALLOF~1\main\localized_english_pak5.pk3 (46 files)
localized assets pak file for english
C:\PROGRA~1\CALLOF~1\main\localized_english_pak3.pk3 (7 files)
localized assets pak file for english
C:\PROGRA~1\CALLOF~1\main\localized_english_pak2.pk3 (9 files)
localized assets pak file for english
C:\PROGRA~1\CALLOF~1\main\localized_english_pak1.pk3 (3736 files)
localized assets pak file for english
C:\PROGRA~1\CALLOF~1\main\localized_english_pak0.pk3 (1204 files)
localized assets pak file for english

File Handles:
----------------------
30160 files in pk3 files
execing default_mp.cfg
couldn't exec language.cfg
execing config_mp.cfg
couldn't exec autoexec_mp.cfg
Hunk_Clear: reset the hunk ok
...detecting CPU, found Intel Pentium III
Measured CPU speed is 3.19 GHz
System memory is 1024 MB (capped at 1 GB)
Video card memory is 512 MB
Streaming SIMD Extensions (SSE) supported

Winsock Initialized
Opening IP socket: localhost:28960
Hostname: STUDY
IP: 192.168.0.4
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
Initializing OpenGL subsystem
...initializing QGL
...calling LoadLibrary( 'C:\WINDOWS\system32\opengl32.dll' ): succeeded
...setting mode 6: 1024 768 W
...registered window class
...created window@0,0 (1030x800)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 32, 24, 8 )
...53 PFDs found
...hardware acceleration found
...PIXELFORMAT 5 selected
...creating GL context: succeeded
...making context current: succeeded
Initializing OpenGL extensions
...ignoring OpenGL 1.2 draw element range
...using OpenGL 1.3 texture add environment mode
...using OpenGL 1.3 texture combine environment mode
...using OpenGL 1.3 texture dot3 environment mode
...using OpenGL 1.3 cube map textures
...using GL_ARB_vertex_program
...GL_NV_texture_shader not found
...GL_NV_register_combiners not found
...using WGL_EXT_swap_control
...using OpenGL 1.3 multitexture
...using GL_EXT_compiled_vertex_array
...using OpenGL 1.2 normal rescaling
...GL_ATI_pn_triangles not found
...using GL_ARB_vertex_buffer_object
...GL_NV_fog_distance not found
...GL_NV_vertex_array_range not found
...GL_NV_fence not found
...ignoring GL_ATI_vertex_array_object
...using GL_ATI_fragment_shader
...ignoring GL_EXT_texture_filter_anisotropic

GL_VENDOR: ATI Technologies Inc.
GL_RENDERER: RADEON X300 x86/SSE2
GL_VERSION: 2.0.5279 WinXP Release
GL_EXTENSIONS: GL_ARB_multitexture GL_EXT_texture_env_add GL_EXT_compiled_vertex_array GL_S3_s3tc GL_ARB_depth_texture GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_multisample GL_ARB_occlusion_query GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_shadow GL_ARB_shadow_ambient GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_transpose_matrix GL_ARB_vertex_blend GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_ATI_draw_buffers GL_ATI_element_array GL_ATI_envmap_bumpmap GL_ATI_fragment_shader GL_ATI_map_object_buffer GL_ATI_separate_stencil GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_ATI_texture_mirror_once GL_ATI_vertex_array_object GL_ATI_vertex_attrib_array_object GL_ATI_vertex_streams GL_ATIX_texture_env_combine3 GL_ATIX_texture_env_route GL_ATIX_vertex_shader_output_point_size GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_object GL_EXT_multi_draw_arrays GL_EXT_packed_pixels GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_wrap GL_EXT_texgen_reflection GL_EXT_texture3D GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object GL_EXT_texture_rectangle GL_EXT_vertex_array GL_EXT_vertex_shader GL_HP_occlusion_test GL_NV_blend_square GL_NV_occlusion_query GL_NV_texgen_reflection GL_SGI_color_matrix GL_SGIS_generate_mipmap GL_SGIS_multitexture GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_SUN_multi_draw_arrays GL_WIN_swap_hint WGL_EXT_extensions_string WGL_EXT_swap_control
WGL_EXTENSIONS: WGL_ARB_extensions_string WGL_ARB_make_current_read WGL_ARB_multisample WGL_ARB_pbuffer WGL_ARB_pixel_format WGL_ARB_render_texture WGL_ATI_pixel_format_float WGL_EXT_extensions_string WGL_EXT_swap_control WGL_ATI_render_texture_rectangle
GL_MAX_TEXTURE_SIZE: 2048
GL_MAX_ACTIVE_TEXTURES_ARB: 8

PIXELFORMAT: color(32-bits) Z(24-bit) stencil(8-bits)
MODE: 6, 1024 x 768 windowed hz:75
GAMMA: hardware w/ 0 overbright bits
CPU: Intel Pentium III
rendering primitives: single glDrawElements
texturemode: GL_LINEAR_MIPMAP_NEAREST
picmip: 2
picmip2: 2
texture bits: 0
multitexture: enabled
compiled vertex arrays: enabled
texenv add: enabled
ATI truform: disabled
NV distance fog: disabled
Initializing Shaders
...loading 'scripts/decals.shader'
...loading 'scripts/hood.shader'
...loading 'scripts/sky.shader'
...loading 'scripts/water.shader'
...loading 'scripts/window.shader'
...loading 'scripts/hud.shader'
...loading 'scripts/ui_menus_mp.shader'
...loading 'scripts/brad.shader'
...loading 'scripts/carride.shader'
...loading 'scripts/cloudshadow.shader'
...loading 'scripts/common.shader'
...loading 'scripts/effects.shader'
...loading 'scripts/gfx.shader'
...loading 'scripts/jeff.shader'
...loading 'scripts/nodlight.shader'
...loading 'scripts/paulj.shader'
...loading 'scripts/river_pj.shader'
...loading 'scripts/sfx.shader'
...loading 'scripts/sun.shader'
...loading 'scripts/surfacelight.shader'
...loading 'scripts/talon.shader'
...loading 'scripts/tankcountry.shader'
...loading 'scripts/tankhud.shader'
...loading 'scripts/terrain.shader'
...loading 'scripts/test.shader'
...loading 'scripts/transparents.shader'
...loading 'scripts/treeshadowtest.shader'
...loading 'scripts/truckride.shader'
...loading 'scripts/ui_hud.shader'
...loading 'scripts/ui_menus.shader'
...loading 'scripts/weapons.shader'
...loading 'fxshaders/jh_fx.shader'
...loading 'fxshaders/pj_fx.shader'
...loading 'fxshaders/pj_impact.shader'
...loading 'fxshaders/weaponfx.shader'
----- finished R_Init -----

------- Miles sound system initialization -------
Attempting 44 kHz 16 bit stereo sound
2D provider initialized at 9369312 0 38403444
available 3D providers:
Aureal A3D Interactive ™
Aureal A3D 2.0 ™
DirectSound3D Software Emulation
DirectSound3D Hardware Support
DirectSound3D 7+ Software - Pan and Volume
DirectSound3D 7+ Software - Light HRTF
DirectSound3D 7+ Software - Full HRTF
Creative Labs EAX 3 ™
Creative Labs EAX 2 ™
Creative Labs EAX ™
RAD Game Tools RSX 3D Audio
Dolby Surround
Miles Fast 2D Positional Audio
using 3D provider 'Miles Fast 2D Positional Audio'
32 max 3D channels
------- Miles successfully initialized -------
file ui_mp/settings_dm.menu, line 6: redefinition of OPTIONS_CONTROL_XALIGN
file ui_mp/settings_tdm.menu, line 6: redefinition of OPTIONS_CONTROL_XALIGN
file ui_mp/settings_sd.menu, line 5: redefinition of OPTIONS_CONTROL_XALIGN
file ui_mp/settings_re.menu, line 5: redefinition of OPTIONS_CONTROL_XALIGN
file ui_mp/settings_bel.menu, line 5: redefinition of OPTIONS_CONTROL_XALIGN
file ui_mp/settings_hq.menu, line 5: redefinition of OPTIONS_CONTROL_XALIGN
--- Common Initialization Complete ---
Working directory: C:\PROGRA~1\CALLOF~1
PunkBuster Client: PunkBuster Client (v1.216 | A0) Enabled
PunkBuster Client: Game Version [COD MP 1.5 build 2040 Nov 16 2004 18:55:03 win-x86]
PunkBuster Client: Not Connected to a Server
----- CL_Shutdown -----
RE_Shutdown( 1 )
Shutting down OpenGL subsystem
...wglMakeCurrent( NULL, NULL ): success
...deleting GL context: success
...releasing DC: success
...destroying window
...shutting down QGL
...unloading OpenGL DLL
-----------------------
------ Server Initialization ------
Server: mp_bocage
Hunk_Clear: reset the hunk ok
----- FS_Startup -----
Current language: english
Current search path:
C:\PROGRA~1\CALLOF~1\main\pakb.pk3 (60 files)
C:\PROGRA~1\CALLOF~1\main\paka.pk3 (41 files)
C:\PROGRA~1\CALLOF~1\main\pak9.pk3 (149 files)
C:\PROGRA~1\CALLOF~1\main\pak8.pk3 (235 files)
C:\PROGRA~1\CALLOF~1\main\pak6.pk3 (3 files)
C:\PROGRA~1\CALLOF~1\main\pak5.pk3 (4858 files)
C:\PROGRA~1\CALLOF~1\main\pak4.pk3 (1668 files)
C:\PROGRA~1\CALLOF~1\main\pak3.pk3 (1992 files)
C:\PROGRA~1\CALLOF~1\main\pak2.pk3 (694 files)
C:\PROGRA~1\CALLOF~1\main\pak1.pk3 (2642 files)
C:\PROGRA~1\CALLOF~1\main\pak0.pk3 (12816 files)
C:\PROGRA~1\CALLOF~1/main
C:\PROGRA~1\CALLOF~1\main\localized_english_pak5.pk3 (46 files)
localized assets pak file for english
C:\PROGRA~1\CALLOF~1\main\localized_english_pak3.pk3 (7 files)
localized assets pak file for english
C:\PROGRA~1\CALLOF~1\main\localized_english_pak2.pk3 (9 files)
localized assets pak file for english
C:\PROGRA~1\CALLOF~1\main\localized_english_pak1.pk3 (3736 files)
localized assets pak file for english
C:\PROGRA~1\CALLOF~1\main\localized_english_pak0.pk3 (1204 files)
localized assets pak file for english

File Handles:
----------------------
60320 files in pk3 files
------- Game Initialization -------
gamename: Call of Duty
gamedate: Dec 23 2004
0 teams with 0 entities
-----------------------------------
-----------------------------------
PunkBuster Server: 0 Aliases Written to pbalias.dat
PunkBuster Server: 0 Stat Records Written to pbstat.dat
PunkBuster Server: Preparing to Disable PB Server... (C:\PROGRA~1\CALLOF~1\pb\)
Hitch warning: 2627 msec frame time
Resolving codmaster.activision.com
codmaster.activision.com resolved to 63.146.124.59:20510
Sending heartbeat to codmaster.activision.com
Resolving codauthorize.activision.com
codauthorize.activision.com resolved to 63.146.124.59:20500

Edited by .:007:., 19 January 2006 - 11:49 AM.

  • 0

#153
jrm20

jrm20

    System building expert

  • Topic Starter
  • Retired Staff
  • 2,394 posts
Yeah its hard to get past some routers so that your server is shown on the net.


For the port forwarding way your lan ip is set wrong... Never end with a zero (0) ever it wont work. Suppost to be the same as the ip address given to the server pc by the router. Lan ip is given by the router has to be the same throughout.
  • 0

#154
.:007:.

.:007:.

    Member

  • Member
  • PipPip
  • 10 posts
What zero (0) are you refering to? The router ip is:192.168.0.1 and my pc is:192.168.0.4

Thnx,
007

Edited by .:007:., 19 January 2006 - 03:22 PM.

  • 0

#155
jrm20

jrm20

    System building expert

  • Topic Starter
  • Retired Staff
  • 2,394 posts

What zero (0) are you refering to? The router ip is:192.168.0.1 and my pc is:192.168.0.4

Thnx,
007





I said it above, the port forwarding image with the lan ip address, it has 0 put it to what the servers actual ip is that is given by the router. Its not suppost to be 0.

Edited by jrm20, 19 January 2006 - 04:41 PM.

  • 0

#156
jrm20

jrm20

    System building expert

  • Topic Starter
  • Retired Staff
  • 2,394 posts
Posted Image




Thats what I said above...
  • 0

#157
.:007:.

.:007:.

    Member

  • Member
  • PipPip
  • 10 posts
That's for adding another port, so the default is (0). If you look below it, there are three ports added that have IP: 192.168.0.4!

Look at the part circled in red:
SBG940_Port_Forwarding_red.JPG

Sry bout the confusion,
007

Edited by .:007:., 19 January 2006 - 05:19 PM.

  • 0

#158
jrm20

jrm20

    System building expert

  • Topic Starter
  • Retired Staff
  • 2,394 posts
I see that now, lol.


If all of your server settings are set right then it has to be something wrong with the router settings of course.


Try to change your lan ip away from 192.168.0.4, the zero in that is the only thing that I see might be causing your problem. When I had a router, I unplugged it and got the ip of 192.168.1.1 for my one and only pc at the time. In my dmz host function all I did was set the dmz ip to 192.168.1.100 and wala it worked. What you have to do is get your server pc to have the ip of 192.168.1.1 and then set the dmz host to 192.168.1.100 and it will work, did for me always and the ip of your server will be 192.168.1.1 for you on the list under internet.


Its hard for me to tell what is wrong with your setup or hardware, basically this post is meant for guiding you how to open the server.

If you read through all of what I posted it has all the information ever needed to successfully open a server with a router.


Basically mess around with what I said, the 192.168. has to stay, but the 192.168.X.X is your problem.

First, in the dmz ip add two zeros to the end of the .4 and see what happens.
  • 0

#159
jrm20

jrm20

    System building expert

  • Topic Starter
  • Retired Staff
  • 2,394 posts
If you still have problems go here...


http://www.olddogvt.net/cod-firewall/
  • 0

#160
DARK_AVENGER

DARK_AVENGER

    New Member

  • Member
  • Pip
  • 3 posts
i have call of duty and whenever i go to start a new server it comes up with the COD consol and it starts loading up it stops and you can see this on the attachment.

so if you have any information of how to stop this it would be very abliged if you could tell me or email me at sjaye24@hotmail.com :tazz:

Attached Files


Edited by DARK_AVENGER, 20 January 2006 - 06:36 AM.

  • 0

Advertisements


#161
jrm20

jrm20

    System building expert

  • Topic Starter
  • Retired Staff
  • 2,394 posts
gamedate: Apr 13 2004
WARNING: Could not load GameType description file maps/mp/gametypes/gen.txt for gametype gen
WARNING: Could not load GameType description file maps/mp/gametypes/mc_bel.txt for gametype mc_bel
WARNING: Could not load GameType description file maps/mp/gametypes/mc_dm.txt for gametype mc_dm
WARNING: Could not load GameType description file maps/mp/gametypes/mc_hq.txt for gametype mc_hq
WARNING: Could not load GameType description file maps/mp/gametypes/mc_re.txt for gametype mc_re
WARNING: Could not load GameType description file maps/mp/gametypes/mc_sd.txt for gametype mc_sd
WARNING: Could not load GameType description file maps/mp/gametypes/mc_tdm.txt for gametype mc_tdm

******* script compile error *******
Could not find script 'maps\mp\gametypes\_bam'
************************************
********************
ERROR: script compile error
(see console for details)



From what I can see your gametype is wrong or invalid. Try making a new map_rotation to fix this error with the appropriate gametypes.
  • 0

#162
.:007:.

.:007:.

    Member

  • Member
  • PipPip
  • 10 posts
Hey,

Could you give me an example of how the console should look!

Thnx,
007
  • 0

#163
jrm20

jrm20

    System building expert

  • Topic Starter
  • Retired Staff
  • 2,394 posts
If it says this at the bottom of the console then it should be good.


Hitch warning: 2627 msec frame time
Resolving codmaster.activision.com
codmaster.activision.com resolved to 63.146.124.59:20510
Sending heartbeat to codmaster.activision.com
Resolving codauthorize.activision.com
codauthorize.activision.com resolved to 63.146.124.59:20500


You know that after the console comes up that you minimized it then go into the game again then find your server on the list.

Dedicated internet
Pure ON
Punkbuster off
  • 0

#164
DARK_AVENGER

DARK_AVENGER

    New Member

  • Member
  • Pip
  • 3 posts
thank you very much for this ifrormation it is greatly apreciated
  • 0

#165
DARK_AVENGER

DARK_AVENGER

    New Member

  • Member
  • Pip
  • 3 posts
when i go on to create a new server now it goes in and i click on game setting and it comes up blank
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP