Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Running a Call of Duty/uo server @home


  • Please log in to reply

#241
MoViEsTaR

MoViEsTaR

    Member

  • Member
  • PipPip
  • 26 posts

I tried doin the port fowarding thing but when i enter the the admin and password after entering ip into the internet it says 401 unthorized.


Some free routers that you get with an internet service wont let you in the settings to alter stuff..

If you have bought the router then you will be able for sure to alter the settings.

Pm me if you want me to go through it with you
  • 0

Advertisements


#242
dormage

dormage

    Member

  • Member
  • PipPip
  • 49 posts
ok my server is kind working ,well the conzolr is!!!!
i have a lan network for 3 comps of mine and my server is only working with lan
connecting to ip trough the cod conzole dosent seem to be an option
i can open ports its just that i dont know witch ports to open
please help me
i need this :whistling:
  • 0

#243
jrm20

jrm20

    System building expert

  • Topic Starter
  • Retired Staff
  • 2,394 posts

I figured it out like 5min after I posted this...

ty for the help anyway

i made it only a 8man server bcz of my internet I get 206kbs to san.fran and I live in New Jersey

do you think I can up the slots if I just keep it private?

and is it bad if I can not see it in internet but other people can and are able to join?



I would probably keep it at 6 clients and never go over 7 total including you in the server.
  • 0

#244
MoViEsTaR

MoViEsTaR

    Member

  • Member
  • PipPip
  • 26 posts

I tried doin the port fowarding thing but when i enter the the admin and password after entering ip into the internet it says 401 unthorized.


Some free routers that you get with an internet service wont let you in the settings to alter stuff..

If you have bought the router then you will be able for sure to alter the settings.

Pm me if you want me to go through it with you


Just allowing DMZ in your router settings can be enough sometimes, if you need to also open ports then open 20-100 range and that should be fine.
  • 0

#245
slayer2746

slayer2746

    New Member

  • Member
  • Pip
  • 8 posts
srry im a real noob at this idk what a dmz is and how do I open my ports.
  • 0

#246
whitewolfmh

whitewolfmh

    New Member

  • Member
  • Pip
  • 1 posts
Anyone!!

I currently am trying to start a COD UO server at this computer. I have a router and I want to start the server behind the router. It has given me much trouble. I would do the DMZ but I am confused as to what to put in. I login to my config at 192.168.2.1 but but Status bar says my Internet IP is 192.168.1.97. I cannot fill in the 2 with a 1 in the DMZ options. I talked with Linksys and they told me to set the static IP to something but I lost my internet by doing that. So it is now set to get IP automatically. I don't know much and I WOULD PRAISE YOU FOREVER IF YOU COULD HELP!!!

Thanks,

WhiteWolf :whistling: :blink: :help:
  • 0

#247
dormage

dormage

    Member

  • Member
  • PipPip
  • 49 posts
ok ibout your ip problem!!!!!
its like this you need to have a static ip (none changing one)cuz now your ip is changing but you can not run a server with a dinamic ip cuz then players wount be able to connect on your comp (if the ip is changing)

to set a static ip you need to run command by klicking start>run>command

than enter ipconfig /all
then configuration WILL OPEN!!!!!
THEN !!! copy your ip,getway,dns(both numbers)&the mask will apear automaticly if not its (255.255.255.0)
now klick on ¨my network places¨>connections and righit click on the lokal area connectons otherwise caled LAN and go to properties select the tcp/ip connection and click properties again.
now youll see that your ip is dinamic so insted of klicking obtain the folowing ip adress klick use folowing adress (same for the DNS)

NOW JUST ENTER THE NUMBERS YOU COPYED BEFOR AND CLICK OK
if the net is working you now have a static ip!! :whistling:
  • 0

#248
dormage

dormage

    Member

  • Member
  • PipPip
  • 49 posts
ok i was wondering if dmz aint inaf tu run the server then witch ports im i to open.
and ožabove all my ruter dosent leave me an options of opening a rang of ip`s so ill just have to open each one of them.
but thats ok !!!
i just wana know iwitch ports to open , at least a range!!!!!!????? :whistling:
  • 0

#249
JollyUnlucky

JollyUnlucky

    New Member

  • Member
  • Pip
  • 1 posts
Hey Jrm20, is it possible to act as an admin in one of these servers or is that only possible when you're running a rented server? :whistling:
  • 0

#250
dormage

dormage

    Member

  • Member
  • PipPip
  • 49 posts
if you own the server (that is if you instald it on your comp) you have administrative righits to access & change anything you wish.
if you buy a server you can access it trough a thing called rcon for remote connection to admintrative righits to server.


anyway the answer is yes!!!!!
  • 0

Advertisements


#251
dormage

dormage

    Member

  • Member
  • PipPip
  • 49 posts
im still waiting for a reply obout port opening for cod server
  • 0

#252
-=ANGEL=-

-=ANGEL=-

    New Member

  • Member
  • Pip
  • 2 posts
First of all massive thanx to jrm20. i stumbled across this forum a week ago googleing "running a cod server". Lol, to be honest i'd done half of starting a server without help, but when the console came up wen i started it it thought it had naft up or summat!!!! LOL wota idiot. Anyway i have no problem launching a normal cod server now (like a pro) but i have downloaded the breaking5o paintball mod (zip not exe) seem to get no joy hosting a server for my mates. I launch mod go to start server with dedicated to internet and pure, get the console as normal and i can find my game straight away but my mates cant see it. Is there summat different i shud be doing or what?
  • 0

#253
-=ANGEL=-

-=ANGEL=-

    New Member

  • Member
  • Pip
  • 2 posts
sorry me again also i just tried to host a swat mod server and got all this in donsole..

...deleting GL context: success
...releasing DC: success
...destroying window
...resetting display
...shutting down QGL
...unloading OpenGL DLL
Hunk_Clear: reset the hunk ok
----- FS_Startup -----
Current language: english
Current search path:
C:\PROGRA~1\CALLOF~1\swatfinal\SWAT010.pk3 (3298 files)
C:\PROGRA~1\CALLOF~1/swatfinal
C:\PROGRA~1\CALLOF~1\main\zzz_Rifle_RangeV1.3.1.pk3 (66 files)
C:\PROGRA~1\CALLOF~1\main\w_awe_cod_v2.1_client.pk3 (43 files)
C:\PROGRA~1\CALLOF~1\main\wawa_3dAim.pk3 (13 files)
C:\PROGRA~1\CALLOF~1\main\pakb.pk3 (60 files)
C:\PROGRA~1\CALLOF~1\main\paka.pk3 (41 files)
C:\PROGRA~1\CALLOF~1\main\pak9.pk3 (149 files)
C:\PROGRA~1\CALLOF~1\main\pak8.pk3 (235 files)
C:\PROGRA~1\CALLOF~1\main\pak6.pk3 (3 files)
C:\PROGRA~1\CALLOF~1\main\pak5.pk3 (4858 files)
C:\PROGRA~1\CALLOF~1\main\pak4.pk3 (1668 files)
C:\PROGRA~1\CALLOF~1\main\pak3.pk3 (1992 files)
C:\PROGRA~1\CALLOF~1\main\pak2.pk3 (694 files)
C:\PROGRA~1\CALLOF~1\main\pak1.pk3 (2642 files)
C:\PROGRA~1\CALLOF~1\main\pak0.pk3 (12816 files)
C:\PROGRA~1\CALLOF~1/main
C:\PROGRA~1\CALLOF~1\main\localized_english_pak5.pk3 (46 files)
localized assets pak file for english
C:\PROGRA~1\CALLOF~1\main\localized_english_pak3.pk3 (7 files)
localized assets pak file for english
C:\PROGRA~1\CALLOF~1\main\localized_english_pak2.pk3 (9 files)
localized assets pak file for english
C:\PROGRA~1\CALLOF~1\main\localized_english_pak1.pk3 (3736 files)
localized assets pak file for english
C:\PROGRA~1\CALLOF~1\main\localized_english_pak0.pk3 (1204 files)
localized assets pak file for english

File Handles:
----------------------
172447 files in pk3 files
----- Initializing Renderer ----
-------------------------------
----- R_Init -----
Initializing OpenGL subsystem
...initializing QGL
...calling LoadLibrary( 'C:\WINDOWS\System32\opengl32.dll' ): succeeded
...setting mode 6: 1024 768 FS
...using colorbits of 32
...calling CDS: ok
...created window@0,0 (1024x768)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 32, 24, 8 )
...39 PFDs found
...hardware acceleration found
...PIXELFORMAT 3 selected
...creating GL context: succeeded
...making context current: succeeded
Initializing OpenGL extensions
...ignoring OpenGL 1.2 draw element range
...using OpenGL 1.3 texture add environment mode
...using OpenGL 1.3 texture combine environment mode
...using OpenGL 1.3 texture dot3 environment mode
...using OpenGL 1.3 cube map textures
...using GL_ARB_vertex_program
...GL_NV_texture_shader not found
...GL_NV_register_combiners not found
...using WGL_EXT_swap_control
...using OpenGL 1.3 multitexture
...using GL_EXT_compiled_vertex_array
...using OpenGL 1.2 normal rescaling
...GL_ATI_pn_triangles not found
...using GL_ARB_vertex_buffer_object
...GL_NV_fog_distance not found
...GL_NV_vertex_array_range not found
...GL_NV_fence not found
...ignoring GL_ATI_vertex_array_object
...using GL_ATI_fragment_shader
...ignoring GL_EXT_texture_filter_anisotropic

GL_VENDOR: ATI Technologies Inc.
GL_RENDERER: RADEON 9200 Series DDR x86/SSE2
GL_VERSION: 1.3.1006 WinXP Release
GL_EXTENSIONS: GL_ARB_multitexture GL_EXT_texture_env_add GL_EXT_compiled_vertex_array GL_S3_s3tc GL_ARB_occlusion_query GL_ARB_point_parameters GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_transpose_matrix GL_ARB_vertex_blend GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_window_pos GL_ATI_element_array GL_ATI_envmap_bumpmap GL_ATI_fragment_shader GL_ATI_map_object_buffer GL_ATI_texture_env_combine3 GL_ATI_texture_mirror_once GL_ATI_vertex_array_object GL_ATI_vertex_attrib_array_object GL_ATI_vertex_streams GL_ATIX_texture_env_combine3 GL_ATIX_texture_env_route GL_ATIX_vertex_shader_output_point_size GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_multi_draw_arrays GL_EXT_packed_pixels GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_stencil_wrap GL_EXT_texgen_reflection GL_EXT_texture3D GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object GL_EXT_texture_rectangle GL_EXT_vertex_array GL_EXT_vertex_shader GL_HP_occlusion_test GL_NV_blend_square GL_NV_occlusion_query GL_NV_texgen_reflection GL_SGI_color_matrix GL_SGIS_generate_mipmap GL_SGIS_multitexture GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_SUN_multi_draw_arrays GL_WIN_swap_hint WGL_EXT_extensions_string WGL_EXT_swap_control
WGL_EXTENSIONS: WGL_ARB_extensions_string WGL_ARB_make_current_read WGL_ARB_pbuffer WGL_ARB_pixel_format WGL_ARB_render_texture WGL_EXT_extensions_string WGL_EXT_swap_control
GL_MAX_TEXTURE_SIZE: 2048
GL_MAX_ACTIVE_TEXTURES_ARB: 6

PIXELFORMAT: color(32-bits) Z(24-bit) stencil(8-bits)
MODE: 6, 1024 x 768 fullscreen hz:60
GAMMA: hardware w/ 0 overbright bits
CPU: Intel Pentium III
rendering primitives: single glDrawElements
texturemode: GL_LINEAR_MIPMAP_LINEAR
picmip: 0
picmip2: 0
texture bits: 32
multitexture: enabled
compiled vertex arrays: enabled
texenv add: enabled
ATI truform: disabled
NV distance fog: disabled
Initializing Shaders
...loading 'scripts/amberville.shader'
...loading 'scripts/oraco.shader'
...loading 'scripts/suburbia.shader'
...loading 'scripts/swat.shader'
...loading 'scripts/rifle_range.shader'
...loading 'scripts/decals.shader'
...loading 'scripts/hood.shader'
...loading 'scripts/sky.shader'
...loading 'scripts/water.shader'
...loading 'scripts/window.shader'
...loading 'scripts/hud.shader'
...loading 'scripts/ui_menus_mp.shader'
...loading 'scripts/brad.shader'
...loading 'scripts/carride.shader'
...loading 'scripts/cloudshadow.shader'
...loading 'scripts/common.shader'
...loading 'scripts/effects.shader'
...loading 'scripts/gfx.shader'
...loading 'scripts/jeff.shader'
...loading 'scripts/nodlight.shader'
...loading 'scripts/paulj.shader'
...loading 'scripts/river_pj.shader'
...loading 'scripts/sfx.shader'
...loading 'scripts/sun.shader'
...loading 'scripts/surfacelight.shader'
...loading 'scripts/talon.shader'
...loading 'scripts/tankcountry.shader'
...loading 'scripts/tankhud.shader'
...loading 'scripts/terrain.shader'
...loading 'scripts/test.shader'
...loading 'scripts/transparents.shader'
...loading 'scripts/treeshadowtest.shader'
...loading 'scripts/truckride.shader'
...loading 'scripts/ui_hud.shader'
...loading 'scripts/ui_menus.shader'
...loading 'scripts/weapons.shader'
...loading 'fxshaders/awe_fx.shader'
...loading 'fxshaders/jh_fx.shader'
...loading 'fxshaders/pj_fx.shader'
...loading 'fxshaders/pj_impact.shader'
...loading 'fxshaders/weaponfx.shader'
----- finished R_Init -----
file ui_mp/settings_dm.menu, line 6: redefinition of OPTIONS_CONTROL_XALIGN
file ui_mp/settings_tdm.menu, line 6: redefinition of OPTIONS_CONTROL_XALIGN
file ui_mp/settings_sd.menu, line 5: redefinition of OPTIONS_CONTROL_XALIGN
file ui_mp/settings_re.menu, line 5: redefinition of OPTIONS_CONTROL_XALIGN
file ui_mp/settings_bel.menu, line 5: redefinition of OPTIONS_CONTROL_XALIGN
execing config_mp.cfg
r_texturebits will be changed upon restarting.
----- CL_Shutdown -----
RE_Shutdown( 1 )
Shutting down OpenGL subsystem
...wglMakeCurrent( NULL, NULL ): success
...deleting GL context: success
...releasing DC: success
...destroying window
...resetting display
...shutting down QGL
...unloading OpenGL DLL
-----------------------
Cmd_AddCommand: say already defined
Cmd_AddCommand: tell already defined
Hitch warning: 1741 msec frame time
------ Server Initialization ------
Server: swat_mayan
Hunk_Clear: reset the hunk ok
----- FS_Startup -----
Current language: english
Current search path:
C:\PROGRA~1\CALLOF~1\swatfinal\SWAT010.pk3 (3298 files)
C:\PROGRA~1\CALLOF~1/swatfinal
C:\PROGRA~1\CALLOF~1\main\zzz_Rifle_RangeV1.3.1.pk3 (66 files)
C:\PROGRA~1\CALLOF~1\main\w_awe_cod_v2.1_client.pk3 (43 files)
C:\PROGRA~1\CALLOF~1\main\wawa_3dAim.pk3 (13 files)
C:\PROGRA~1\CALLOF~1\main\pakb.pk3 (60 files)
C:\PROGRA~1\CALLOF~1\main\paka.pk3 (41 files)
C:\PROGRA~1\CALLOF~1\main\pak9.pk3 (149 files)
C:\PROGRA~1\CALLOF~1\main\pak8.pk3 (235 files)
C:\PROGRA~1\CALLOF~1\main\pak6.pk3 (3 files)
C:\PROGRA~1\CALLOF~1\main\pak5.pk3 (4858 files)
C:\PROGRA~1\CALLOF~1\main\pak4.pk3 (1668 files)
C:\PROGRA~1\CALLOF~1\main\pak3.pk3 (1992 files)
C:\PROGRA~1\CALLOF~1\main\pak2.pk3 (694 files)
C:\PROGRA~1\CALLOF~1\main\pak1.pk3 (2642 files)
C:\PROGRA~1\CALLOF~1\main\pak0.pk3 (12816 files)
C:\PROGRA~1\CALLOF~1/main
C:\PROGRA~1\CALLOF~1\main\localized_english_pak5.pk3 (46 files)
localized assets pak file for english
C:\PROGRA~1\CALLOF~1\main\localized_english_pak3.pk3 (7 files)
localized assets pak file for english
C:\PROGRA~1\CALLOF~1\main\localized_english_pak2.pk3 (9 files)
localized assets pak file for english
C:\PROGRA~1\CALLOF~1\main\localized_english_pak1.pk3 (3736 files)
localized assets pak file for english
C:\PROGRA~1\CALLOF~1\main\localized_english_pak0.pk3 (1204 files)
localized assets pak file for english

File Handles:
----------------------
206027 files in pk3 files
------- Game Initialization -------
gamename: Call of Duty
gamedate: Nov 10 2004
********************
ERROR: Max ammo mismatch for "usgrenade" ammo: 'frag_mp" set it to 3, but "fraggrenade_mp" already set it to 999.

********************
----- Server Shutdown -----
Resolving codmaster.activision.com
codmaster.activision.com resolved to 63.146.124.59:20510
Sending heartbeat to codmaster.activision.com
==== ShutdownGame ====
---------------------------
Hunk_Clear: reset the hunk ok
Hitch warning: 4102 msec frame time
Hitch warning: 8440 msec frame time

Please wot do i do
  • 0

#254
cheesemonsta

cheesemonsta

    New Member

  • Member
  • Pip
  • 2 posts
hey jrm.... ya my server werks and all... but the only thing is that it never appears in the internet.... i get it in the local but no one else can c it... i always keep the console box up... i just minimize it it says what you said it should say.... about sending the heart beat to activision n that [bleep] but it NEVER appears on the internet thing :blink: :help: :) i dont know what to do... and all my friends get theirs up but they dont know what they did so they cant help me.... so mayb you could help me... cuz i know all the setting and stuff and how to change the map and how to kick people (heh heh.. but just not know how to set aq map rotation but thats a diff story) and how to get a modded server but i want a regular server for now and i was wondering if you could help me so that everyone can c it :woot: thanxx soooooo much in advanced cuz i know you will help me.... o and i know the IP adress and my router is DSL gateway belkin router.... windows XP :whistling: thanx
  • 0

#255
jrm20

jrm20

    System building expert

  • Topic Starter
  • Retired Staff
  • 2,394 posts
Goto http://www.portforwa...tforwarding.htm for the ports for Call of duty or Call of duty United offensive... It has been talked about several times if you just took the time to look through the forum. Im not ignoring your posts its just that all of your questions have been answered several times already.

This is a huge topic and the same questions keep coming, Please look through the forum there is several different topics about everyones problems.

If you think you have opened the ports up right for Call of duty or Call of duty united offensive and it still shows on local after you set all of the server settings correctly also, you need to goto portforward.com and try and find your routers model and look it up. If its not on the portforward site then download Router Screenshot Grabber and run the program then follow the instructions so that the guys at portforward.com can try to write a review for your router to help you out. Sometimes they cannot get info so you will have to go back to reading through the forum again.

**FOR PEOPLE WANTING TO HOST AN INTERNET SERVER AT HOME** **NOT FOR LAN**
If you opened a Server with the option Dedicated to Internet and you set up the port forwarding within the router and the server still does NOT show up on internet list it means you set up the ports incorrectly somehow or either you may have a firewall of some type blocking it such as a software firewall. There is really know way for me to explain it any better than I already have many times in this forum. I cant fix your problem because Im not their at your house looking at the problem to troubleshoot it.

**When a server is set up correctly on the same pc as you will be playing on, your servers hostname will show up on both internet and lan lists after you refresh the lists...**

Make shure You set Dedicated To Internet! Dont keep Dedicated to NO, Or LAN!!

If you are having problems you should see if a server will work this way first. Try to make an internet server by going to start new server in the cod or cod uo menu then fill out all of your settings correctly under the general tab. Set Dedicated to Internet, set a hostname, set a min and max ping if you want, set a maxrate if you want, Put it on Pure server, set maxplayers appropriately, put punkbuster off for now, do not set a password unless you want a private server that you give your friends the pass and only they can connect..

After that select a map and gametype then click START.

You will then goto back to the desktop and a console box will open which is normal!! Leave that box alone and minimize it!! Now, start back up call of duty and try to find your server on the internet list and lan both!!

Make shure you Refresh the Internet list! If your server shows up on the internet list it means your server is set up correctly and people will be able to join your server.

If you still dont see your server on the internet list you have a problem with your ports for the game or you set it up incorrectly or in the wrong place.. A firewall can also cause your server not to show up on the internet list...


***IF you have tryed everything and you still have no luck the last option would be to open DMZ Host in your router.***

The DMZ Host allows your lan ip provided by your router to be shown on the internet so people can see your ip. It basically turns off the firewall so people can see your lan ip.


Thats all I can help you with I have already explained this same Information all above many times.
:whistling:

Edited by jrm20, 16 August 2006 - 05:34 PM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP