Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Running a Call of Duty/uo server @home


  • Please log in to reply

#286
SomeUberNoober

SomeUberNoober

    New Member

  • Member
  • Pip
  • 4 posts
I guess I'm a bit late for this post (fingers crossed that some kind perosn will reply).

The situation is that I (like many) am trying to host a Call of duty (United Offensive) server from my home.

Server Specs are:

AMD Athlon 64FX 3200+

MSI K8T Neo

ATI Radeon 9800SE 128MB 128BIT

80Gb HDD

1024MB RAM

Win XP OS

Siemens Speedstream 4200 modem (ISP standard "Handout")

Lights, Fans, etc.

It's a some what out dated setup but it will serve its use...

Thats not the problem though...you see i am having ALOT of trouble trying to get my server to list in the "Internet" list.

ATM it only shows in "Local", and even on stuff like Gamespy Arcade it doesnt show at all???

Wait until you hear this!

So if its on my local list, and not on Gamespy Arcade...people cant possibly get to it...right??? But guess what, I let it run for the day (in desperate hope of it working) and 2 people join to my server which isnt really "There"...then soon after leave.

Wierd...people connected to my "Invisble" server.

(LOL new and improved stealth server, great for not getting any people to join *imagines lame TV advertisment*)

I know I am setting the server up correctly becuase I was stuffing around b4 with my ISDN connection and managed to make a server...that showed up in the Internet list. So now I try the same set up on my new internet (DSL) and it doesnt work.

And the only difference between the two internet connections were the fact that the DSL modem has a router...thats whats causing the problem.

Its fiewall blocks my server.

So i thought how can i go about this?

Use no router; nah modem router in one...

Port Forward; tried it, no sucess/didn't wok...

Use a DMZ; my modem doesnt have a conventional DMZ, they tried to be technologically advanced and make a virtual DMZ (in a nutshell it is, a DMZ that really isnt there but it is - if u kno what i mean).

So if these things dont work...what is left to do (besides the use of extensive pyrotechnics on my some what piece of crap modem - Siemens Speedstream 4200).

I really would HATE having to bo buy a new modem that is more user friendly and better "Setup" just so i can run a server...

A friend and i spent 3 hours trying different modem configurations just trying to ping my computer - the end result = NOTHING. I've tried countless times changing different varibles trying to make a workable server but all I manged was reseting the modem to factory default 5 (at least) times...

Please see if you can one, decipher this random garbage i spat out, and two; help me becuase hosting my own server would be the best thing ever...........*flashbacks to old server with dial up - 5th person connects then server lags up* it was fun...untill too many ppl came...but now i hope to go some proper hosting once I work this junk out.

Yes, I've tried to read the manual (Read The *You can elaborate here* Manual). Google search for Siemens Speedstream 4200 manual (pdf) if u might need one to help sort this out...

Please get back to me with any thoughts or solutions; anything wouold be greatly appreciated!!!

!!!THANKS FOR YOUR TIME!!!

BTW - If it helps...when i connect to my server (through local 'cuz thats where it only shows) it says connecting to 10.0.0.1:28960...it should connect to my external ip or something??? I dont know (server doesnt work thats why :whistling: LOL).

Also, Static IP my not be nesseary because (at this time) i wont have a site with it posted...Server Only will run when i want it - few days in a row...

Agian, Cyas and thanks for any help...
  • 0

Advertisements


#287
SomeUberNoober

SomeUberNoober

    New Member

  • Member
  • Pip
  • 4 posts
Sry, but its me agian..i missed out some basic stuff from b4...

I have got it to run (the server that is)

Olny visible in local, not in internet

but sumone (3 people) managed joined ???

What the...?!?!?

internal ip is 10.0.0.1

gateway is 10.0.0.138

subnetmask is 255.255.255.0

and external ip is 58.xxx.xxx.xx

OMG i cant belive how much work you have gone to jrm20 by answering these questions...and how frustating it is...like when u lost ur patience b4 and soon after sum guys sed "I understand how hard it is but just answer this last question - i need to unblock the firewall" LAWL ur WHOLE post was on unblocking the firewall (or overcoming it anyway).

Thanks for your time - awsome job of ur commitment and monitoring *2 thumbs up*
  • 0

#288
jrm20

jrm20

    System building expert

  • Topic Starter
  • Retired Staff
  • 2,394 posts

Sry, but its me agian..i missed out some basic stuff from b4...

I have got it to run (the server that is)

Olny visible in local, not in internet

but sumone (3 people) managed joined ???

What the...?!?!?

internal ip is 10.0.0.1

gateway is 10.0.0.138

subnetmask is 255.255.255.0

and external ip is 58.xxx.xxx.xx

OMG i cant belive how much work you have gone to jrm20 by answering these questions...and how frustating it is...like when u lost ur patience b4 and soon after sum guys sed "I understand how hard it is but just answer this last question - i need to unblock the firewall" LAWL ur WHOLE post was on unblocking the firewall (or overcoming it anyway).

Thanks for your time - awsome job of ur commitment and monitoring *2 thumbs up*


If it works and people can join then leave everything alone, its fine. Can your friends join your server with no problems?
  • 0

#289
jrm20

jrm20

    System building expert

  • Topic Starter
  • Retired Staff
  • 2,394 posts

I guess I'm a bit late for this post (fingers crossed that some kind perosn will reply).


Use no router; nah modem router in one...

Port Forward; tried it, no sucess/didn't wok...

Use a DMZ; my modem doesnt have a conventional DMZ, they tried to be technologically advanced and make a virtual DMZ (in a nutshell it is, a DMZ that really isnt there but it is - if u kno what i mean).


So do you have a modem / router combo or what?

A modem doesnt have DMZ only the router does. DMZ is last resort if you cannot get the server to work under port forwarding..


Under port forwarding its suppost to work.

Some people have really crappy routers that wont work at all I have seen a few guys that could not get it to work nomatter what.

I then suggest them in renting a server from a host.
  • 0

#290
SomeUberNoober

SomeUberNoober

    New Member

  • Member
  • Pip
  • 4 posts
oh well looks like id have to bite the bullet and buy a new modem. probally a dlink or linksys.

Thanks for your help anyway.

If it aint broke, dont fix it.

If it wont work it is broke.

If you cant fix it, buy a new one :whistling:
  • 0

#291
Mediadirect

Mediadirect

    New Member

  • Member
  • Pip
  • 9 posts
So far, i'm pretty sure i've done everything right. Once I get good upload speed, I plan to go into buiness with hosting CoD servers. But, I have followed all the steps and once I launch call of duty uo, in consol all it says is execing dedicated.cfg and nothing after that. When I got to search for a server under "Local" nothing appears and if I got into consol and type connect localhost:28960 all it does is await connections...
  • 0

#292
jrm20

jrm20

    System building expert

  • Topic Starter
  • Retired Staff
  • 2,394 posts

So far, i'm pretty sure i've done everything right. Once I get good upload speed, I plan to go into buiness with hosting CoD servers. But, I have followed all the steps and once I launch call of duty uo, in consol all it says is execing dedicated.cfg and nothing after that. When I got to search for a server under "Local" nothing appears and if I got into consol and type connect localhost:28960 all it does is await connections...



You shouldnt have to type connect localhost at all...

It will show up on the interent and local list both if you have everything set up correctly with your router and all. Use Port forwarding and not DMZ host unless you have tried absolutely everything and it still wont work. In the console if it doesnt say resolved to cod master server at the bottom then your server is not going to work and you probably have a config file messed up somewhere.
  • 0

#293
Mediadirect

Mediadirect

    New Member

  • Member
  • Pip
  • 9 posts
Okay, this works for both call of duty UO and call of duty right?
  • 0

#294
jrm20

jrm20

    System building expert

  • Topic Starter
  • Retired Staff
  • 2,394 posts

Okay, this works for both call of duty UO and call of duty right?


**This is for the average user to run a server quickly and easily at home for his own personal use and not for running a business at home**


This is for cod and cod uo as stated in the topic. Remember there is a few different ways to run a server with different options. You dont have to use the server.cfg file that I posted on the very first page if you infact used it.

To start up a server quickly just goto start new server then fill out the options. Put it to dedicated Internet, put a hostname, punkbuster on or off select gametype and map then hit start its very simple..

Thats the easy way to get the server to run and you do not need to setup anything in a config file or replace / edit anything.


It will show up on the internet list if you set up the ports in your router. If it does not show up the router is having a conflict and you need to fix the settings you have set wrong.

If you have tried everything and your server will still not show up on the internet with a router then simply dont use the Router at all.. Hook the dsl/cable modem directly to your pc and it will work.

Edited by jrm20, 18 December 2006 - 07:04 PM.

  • 0

#295
Mediadirect

Mediadirect

    New Member

  • Member
  • Pip
  • 9 posts
Alright thanks alot man for the info!
  • 0

Advertisements


#296
SomeUberNoober

SomeUberNoober

    New Member

  • Member
  • Pip
  • 4 posts

Okay, this works for both call of duty UO and call of duty right?


**This is for the average user to run a server quickly and easily at home for his own personal use and not for running a business at home**


This is for cod and cod uo as stated in the topic. Remember there is a few different ways to run a server with different options. You dont have to use the server.cfg file that I posted on the very first page if you infact used it.

To start up a server quickly just goto start new server then fill out the options. Put it to dedicated Internet, put a hostname, punkbuster on or off select gametype and map then hit start its very simple..

Thats the easy way to get the server to run and you do not need to setup anything in a config file or replace / edit anything.


It will show up on the internet list if you set up the ports in your router. If it does not show up the router is having a conflict and you need to fix the settings you have set wrong.

If you have tried everything and your server will still not show up on the internet with a router then simply dont use the Router at all.. Hook the dsl/cable modem directly to your pc and it will work.



Hooking it straight to the comp is good and all that if (yes there is always an if) you have a separate modem and router.

However, im my case i have them in a combo so now i cant get my server to work (port forwarding doesnt work as it should and i tried EVERYTHING).

So im clueless as of what to do now...
  • 0

#297
Mediadirect

Mediadirect

    New Member

  • Member
  • Pip
  • 9 posts
Alright, I got it working (finally) Anyway, would it require Rack Servers to have multiple CoD servers running at once?
  • 0

#298
Jazza

Jazza

    Member

  • Member
  • PipPipPip
  • 240 posts
Even Though I don't know what that is I would say so because I can't get more than one server running at once. (Just tried)
  • 0

#299
dormage

dormage

    Member

  • Member
  • PipPip
  • 49 posts
Hey remember me??
hehe
i cant figur this out

COD MP 1.1 build win-x86 Oct 8 2003
----- FS_Startup -----
Current language: english
Current search path:
D:\Call of Duty\main\pakb.pk3 (60 files)
D:\Call of Duty\main\paka.pk3 (41 files)
D:\Call of Duty\main\pak9.pk3 (149 files)
D:\Call of Duty\main\pak8.pk3 (235 files)
D:\Call of Duty\main\pak6.pk3 (3 files)
D:\Call of Duty\main\pak5.pk3 (4858 files)
D:\Call of Duty\main\pak4.pk3 (1668 files)
D:\Call of Duty\main\pak3.pk3 (1992 files)
D:\Call of Duty\main\pak2.pk3 (694 files)
D:\Call of Duty\main\pak1.pk3 (2642 files)
D:\Call of Duty\main\pak0.pk3 (12816 files)
D:\Call of Duty/main

File Handles:
----------------------
30181 files in pk3 files
execing default_mp.cfg
couldn't exec language.cfg
execing config_mp.cfg
couldn't exec autoexec_mp.cfg
Hunk_Clear: reset the hunk ok
...detecting CPU, found AMD w/ 3DNow!
Measured CPU speed is 1.11 GHz
System memory is 192 MB (capped at 1 GB)
Video card memory is 64 MB
Streaming SIMD Extensions (SSE) supported

Winsock Initialized
Opening IP socket: localhost:28960
Hostname: uporabni-c494e7
IP: 192.168.1.2
--- Common Initialization Complete ---
Working directory: D:\Call of Duty
execing dedicated.cfg
net_ip will be changed upon restarting.
sv_maxclients will be changed upon restarting.
logfile opened on Sat Dec 30 18:18:31 2006

map_rotate...

"sv_mapRotation" is:"gametype dm map mp_hurtgen map mp_neuville map mp_pavlov gametype tdm map mp_harbor map mp_hurtgen map mp_neuville gametype sd map mp_neuville map mp_pavlov map mp_railyard gametype re map mp_depot map mp_harbor map mp_hurtgen gametype bel map mp_neuville map mp_pavlov map mp_railyard gametype hq map mp_pavlov map mp_railyard map mp_rocket "

"sv_mapRotationCurrent" is:""

Setting g_gametype: dm.
Setting map: mp_hurtgen.
------ Server Initialization ------
Server: mp_hurtgen
Hunk_Clear: reset the hunk ok
----- FS_Startup -----
Current language: italian
Current search path:
D:\Call of Duty\main\pakb.pk3 (60 files)
D:\Call of Duty\main\paka.pk3 (41 files)
D:\Call of Duty\main\pak9.pk3 (149 files)
D:\Call of Duty\main\pak8.pk3 (235 files)
D:\Call of Duty\main\pak6.pk3 (3 files)
D:\Call of Duty\main\pak5.pk3 (4858 files)
D:\Call of Duty\main\pak4.pk3 (1668 files)
D:\Call of Duty\main\pak3.pk3 (1992 files)
D:\Call of Duty\main\pak2.pk3 (694 files)
D:\Call of Duty\main\pak1.pk3 (2642 files)
D:\Call of Duty\main\pak0.pk3 (12816 files)
D:\Call of Duty/main
D:\Call of Duty\main\localized_italian_pak5.pk3 (53 files)
localized assets pak file for italian
D:\Call of Duty\main\localized_italian_pak4.pk3 (3 files)
localized assets pak file for italian
D:\Call of Duty\main\localized_italian_pak3.pk3 (7 files)
localized assets pak file for italian
D:\Call of Duty\main\localized_italian_pak2.pk3 (12 files)
localized assets pak file for italian
D:\Call of Duty\main\localized_italian_pak1.pk3 (3736 files)
localized assets pak file for italian
D:\Call of Duty\main\localized_italian_pak0.pk3 (1212 files)
localized assets pak file for italian

File Handles:
handle 1: console_mp.log
----------------------
60362 files in pk3 files
********************
ERROR: SV_SetConfigstring: bad index -1

********************
----- Server Shutdown -----
Resolving codmaster.activision.com
codmaster.activision.com resolved to 63.146.124.59:20510
Sending heartbeat to codmaster.activision.com
Resolving master.gamespy.com:28960
master.gamespy.com:28960 resolved to 207.38.11.34:20510
Sending heartbeat to master.gamespy.com:28960
Resolving clanservers.net
clanservers.net resolved to 208.167.225.2:20510
Sending heartbeat to clanservers.net
Resolving codauthorize.activision.com
codauthorize.activision.com resolved to 63.146.124.59:20510
Sending heartbeat to codauthorize.activision.com
---------------------------
Hunk_Clear: reset the hunk ok
Hitch warning: 339465 msec frame time
What the...?? is that error on sv_xxx something????
  • 0

#300
jrm20

jrm20

    System building expert

  • Topic Starter
  • Retired Staff
  • 2,394 posts

Hey remember me??
hehe
i cant figur this out

COD MP 1.1 build win-x86 Oct 8 2003
----- FS_Startup -----
Current language: english
Current search path:
D:\Call of Duty\main\pakb.pk3 (60 files)
D:\Call of Duty\main\paka.pk3 (41 files)
D:\Call of Duty\main\pak9.pk3 (149 files)
D:\Call of Duty\main\pak8.pk3 (235 files)
D:\Call of Duty\main\pak6.pk3 (3 files)
D:\Call of Duty\main\pak5.pk3 (4858 files)
D:\Call of Duty\main\pak4.pk3 (1668 files)
D:\Call of Duty\main\pak3.pk3 (1992 files)
D:\Call of Duty\main\pak2.pk3 (694 files)
D:\Call of Duty\main\pak1.pk3 (2642 files)
D:\Call of Duty\main\pak0.pk3 (12816 files)
D:\Call of Duty/main

File Handles:
----------------------
30181 files in pk3 files
execing default_mp.cfg
couldn't exec language.cfg
execing config_mp.cfg
couldn't exec autoexec_mp.cfg
Hunk_Clear: reset the hunk ok
...detecting CPU, found AMD w/ 3DNow!
Measured CPU speed is 1.11 GHz
System memory is 192 MB (capped at 1 GB)
Video card memory is 64 MB
Streaming SIMD Extensions (SSE) supported

Winsock Initialized
Opening IP socket: localhost:28960
Hostname: uporabni-c494e7
IP: 192.168.1.2
--- Common Initialization Complete ---
Working directory: D:\Call of Duty
execing dedicated.cfg
net_ip will be changed upon restarting.
sv_maxclients will be changed upon restarting.
logfile opened on Sat Dec 30 18:18:31 2006

map_rotate...

"sv_mapRotation" is:"gametype dm map mp_hurtgen map mp_neuville map mp_pavlov gametype tdm map mp_harbor map mp_hurtgen map mp_neuville gametype sd map mp_neuville map mp_pavlov map mp_railyard gametype re map mp_depot map mp_harbor map mp_hurtgen gametype bel map mp_neuville map mp_pavlov map mp_railyard gametype hq map mp_pavlov map mp_railyard map mp_rocket "

"sv_mapRotationCurrent" is:""

Setting g_gametype: dm.
Setting map: mp_hurtgen.
------ Server Initialization ------
Server: mp_hurtgen
Hunk_Clear: reset the hunk ok
----- FS_Startup -----
Current language: italian
Current search path:
D:\Call of Duty\main\pakb.pk3 (60 files)
D:\Call of Duty\main\paka.pk3 (41 files)
D:\Call of Duty\main\pak9.pk3 (149 files)
D:\Call of Duty\main\pak8.pk3 (235 files)
D:\Call of Duty\main\pak6.pk3 (3 files)
D:\Call of Duty\main\pak5.pk3 (4858 files)
D:\Call of Duty\main\pak4.pk3 (1668 files)
D:\Call of Duty\main\pak3.pk3 (1992 files)
D:\Call of Duty\main\pak2.pk3 (694 files)
D:\Call of Duty\main\pak1.pk3 (2642 files)
D:\Call of Duty\main\pak0.pk3 (12816 files)
D:\Call of Duty/main
D:\Call of Duty\main\localized_italian_pak5.pk3 (53 files)
localized assets pak file for italian
D:\Call of Duty\main\localized_italian_pak4.pk3 (3 files)
localized assets pak file for italian
D:\Call of Duty\main\localized_italian_pak3.pk3 (7 files)
localized assets pak file for italian
D:\Call of Duty\main\localized_italian_pak2.pk3 (12 files)
localized assets pak file for italian
D:\Call of Duty\main\localized_italian_pak1.pk3 (3736 files)
localized assets pak file for italian
D:\Call of Duty\main\localized_italian_pak0.pk3 (1212 files)
localized assets pak file for italian

File Handles:
handle 1: console_mp.log
----------------------
60362 files in pk3 files
********************
ERROR: SV_SetConfigstring: bad index -1

********************
----- Server Shutdown -----
Resolving codmaster.activision.com
codmaster.activision.com resolved to 63.146.124.59:20510
Sending heartbeat to codmaster.activision.com
Resolving master.gamespy.com:28960
master.gamespy.com:28960 resolved to 207.38.11.34:20510
Sending heartbeat to master.gamespy.com:28960
Resolving clanservers.net
clanservers.net resolved to 208.167.225.2:20510
Sending heartbeat to clanservers.net
Resolving codauthorize.activision.com
codauthorize.activision.com resolved to 63.146.124.59:20510
Sending heartbeat to codauthorize.activision.com
---------------------------
Hunk_Clear: reset the hunk ok
Hitch warning: 339465 msec frame time
What the...?? is that error on sv_xxx something????



Sounds like something in your dedicated.cfg file is messed up or either the map rotation.

Try making a backup of the map rotation then putting just 1 map in it with dm.


// Map Rotation
set g_gametype "dm"
set sv_mapRotation "gametype dm map mp_carentan "

I dont know how exactly you are opening your server. There is many ways..

Have you tried going into the cod main menu then going to start server that way? Its the easiest.


If you need help on your config file go here..

http://asylum-gamese...s.com/coduo.php
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP