Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Busted Flashdrive?

  • Please log in to reply




  • Member
  • PipPip
  • 18 posts
Hi there geeks! :) ( I mean that in a loving way)

I am having trouble putting files in my flashdrive. It is a 1G Transcend flashdrive and its been with me for about 3 years now. I have no files in it whatsoever, but whenever I try to put a new file, even as small as a 1KB file, a window that says "The item cannot be copied because there is not enough free space" pops up. How come?

Is it because my flashdrive has exceeded its life span (if there is such a thing) and is therefore busted? or is there some virus I cannot see???

Please help! :)

btw, I almost always eject it the proper way.

Edited by jinkydinkydinx, 09 November 2009 - 10:49 AM.

  • 0




    Member 4k

  • Member
  • PipPipPipPipPipPipPip
  • 4,302 posts
Hi jinkydinkydinx and welcome to Geeks to Go.

As with anything there is a life expectancy. We just don't know what that is.
The drive will not "stop working" after x number of years though.

Can you view the drive in "my computer"?
If so, is anything shown as being on it?
Did you try formatting it?
Have you tried scanning it with your virus scanner?

  • 0




  • Topic Starter
  • Member
  • PipPip
  • 18 posts
Hi 123runner!

First of all, thanks for replying.

I am using a a MAC I book G4 and the operating system is MAC OSX version 10.4.11. There is no "my computer" icon however, I can' view the drive in my desktop everytime I put it in.

When I double click it to see what's inside, there is nothing on it.

No, I haven't tried to reformat it, and I do not know if I unwittingly have.. :)

I do not have a virus scanner :)

By the way, I tried the "get info" button and I noticed something odd :)
Here is what I saw:

General Info:

Kind: Volume
Modified: Tuesday, January 1, 1980 12:00AM
Fromat:MS-Dos File System (FAT16)
Capacity:969.7 MB
Available:1.2 MB
Used: 968.5MB on disk (1,015,578,624 bytes)

-----does my MAC laptop have something to do with it? Whenever I turn it on the date is incorrect and a window that says something like "this computer's date and time is not properly set... it will be erratic?" pops up. Also, I have been getting pop ups which says "you do not have enough space in your startup disk.." . To remedy this, I have deleted some of my previous files in the secure empty trash....

Thanks for the help! :)

and to to the other geeks out there, PLEASE POST! I NEED MY FLASHDRIVE FOR SCHOOL :)

Edited by jinkydinkydinx, 10 November 2009 - 07:56 AM.

  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP