Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Vista not powering up after instaling ISODisk ! PLEASE HELP!


  • Please log in to reply

#1
Ms.Island

Ms.Island

    New Member

  • Member
  • Pip
  • 2 posts
Hello,

I've just installed ISODisk on my pc and under finish it had to restart. But it doesn't power up anymore! The screen is black though I can see and hear as it would be on.
I am writing from a friends pc and have no idea what to do... I beg for any help please!........

Best

Simone :)
  • 0

Advertisements


#2
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
Hello Ms.Island...

Try tapping the F8 key as the machine starts to access the Advanced Boot Options screen. Once there, use the arrow keys to select "Safe Mode" and press Enter.

If you are able to start the machine in Safe Mode, run a system restore (Start > All Programs > Accessories > System Tools > System Restore) to a date before you installed ISODisk.

wannabe1
  • 0

#3
Ms.Island

Ms.Island

    New Member

  • Topic Starter
  • Member
  • Pip
  • 2 posts
Dear wannabe1

thank you for reply. Tried that, didn't work :)
  • 0

#4
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
Do you have your Vista installation cd?
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP