Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

External Hard drive - Deskstar T7K500 - corrupt and unreadable

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
Hi there,

I have a Hitachi Deskstar T7K500 320 GB hard drive housed in a Rocketfish 2.5" case. It's worked fine for over two years, but as of now it won't let me access it.

It does register in My Computer as usual as D: drive, but when I try to open it I just get that beautiful XP sound that means "screw you buddy, no data for you!"

Good thing - I do hear the "firing up the engines" high pitch sound, but I only get a second of the crackling "scanning the data" sound before I get the pop up indicating "Drive D: The file is corrupted and unreadable."

I've taken the case apart, reattached everything, and all the connections are good. I've tried it on different USB ports and even another computer. I'm not sure if it's a problem with the Rocketfish case (I hope it is) or the actual drive (I hope not, because every picture I've taken over the last 5 years is on there).

BTW - I have to admit I did one thing you aren't supposed to - I was in a hurry, switching USB ports, and I unplugged it and plugged back in really fast a couple times - and since then it's not talking to me anymore. Drivers? Or burned a chip?

Please advise! Reformatting is not an option, and neither is a 1000 bucks for data recovery.

Thanks in advance:)

Edited by djwaldo, 15 November 2009 - 09:05 PM.

  • 0




    Portlock - Oahu

  • Member
  • PipPipPipPipPip
  • 2,793 posts
Unfortunately, there is no way to test the drive unless you can install it into another enclosure. If you can't borrow one, you can purchase one from any computer store. Yes, not using the USB eject can corrupt the hard drive... just like it does so many flash drives. Hopefully it's the enclosure and not the file system.
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP