Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Help with Dell printer that won't print

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
I have a Dell Photo 966 AIO printer (Vista OS, Dell Dimension 9200/XPS410) that will print sometimes and sometimes it won't. Here is the "cycle" it inevitably goes through:

1. I will power up system and any print jobs left from the day before (that wouldn't print) go ahead and print, clearing queue.

2. On trying to print anything further, I receive the error message "communication not available." Sometimes, if I'm lucky enough to get one document to print shortly after power up, I receive the message "printer status window interface stopped working and was closed."

Here is what I've done so far to remedy the solution:

1. Uninstalled driver, ran patch from Dell, and reinstalled driver (32 bit).

2. Ran through diagnostics for printer troubleshooting on dell.com. At end of this, ran a test page successfully.

3. Unchecked UAC (user account control) at one point, which allowed printer to print one page and then problem started again. I have since rechecked UAC.

4. Tried a new USB cord for the heck of it and have the same sporadic print problem.

5. Reset computer back two weeks and have same problem.

6. Noted this whole problem started shortly after I downloaded Adobe 9. I have since uninstalled Adobe 9 and reinstalled 9.2. I also ran Microsoft Installer Cleaner prior to installation of 9.2.

7. Checked each USB root hub to make sure device working properly and noted box was unchecked for "allow computer to turn off this device to save power."

8. Checked the obvious to make sure printer has green icon with white checkmark as "ready."

What the heck am I missing? Thanks for any help you can give.
  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP