Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Major Issues with Facebook and YouTube in Firefox 3.5

  • Please log in to reply




  • Member
  • PipPip
  • 82 posts

I'm having some seriously annoying issues with youtube and facebook in Firefox 3.5 that i'm hoping someone may be able to help me with. When I go onto youtube, I will start looking at a few videos and things will work fine...then after watching about 4/5 videos when I try to click on more videos to watch they just hang and won't load. Then the whole page won't even refresh and doing a search will also just do nothing. Sometimes if I just click the video link for like 30 times in quick succesion it may load eventually but usually not. Then if I leave the site for a few minutes and return it will work again but then do the same thing. very annoying

Facebook is also causing me problems. Sometimes I will try and click on normal links like home/profile/inbox etc and it just won't go to them. The real problem though is the chat. When I try and chat it appear to work, however after i've written a couple of replies it will just stop letting me type, so I then have to shrink the chat box and re-enlarge it and then it will allow me to continue typing. Again a small issue but very annoying. When someone chats to me it also makes a wierd click sound and for a split second when they are sending me an isntant message it disables me from doing anything in the browser at all.

I think the problems may also occur in internet explorer although I'm not sure so will have to check. But I hate IE and never use it anyway so it doesn't really matter tbh.

Any help on these issues will be greatly appreciated.


ps. If it's any help I am running XP HOME SP3 on a A 3Ghz P4 dell dimension desktop with 3GB Ram and 250gb HDD.

Edited by sere83, 23 November 2009 - 07:12 PM.

  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP